Sie sind nicht angemeldet.

Beiträge: 93

Registrierungsdatum: 9. Februar 2021

  • Nachricht senden

141

Mittwoch, 16. Juni 2021, 15:55

Behalte den "new_mods" und "projects" Ordner und lösche den Rest.

Dann einfach die neue Version in das Verzeichnis.


So mache ich das immer. Damit solltst Du alles haben was Du brauchst.



danke
  Berater von Fishboss

aktiv in Mod Community ob tester idee beratung oder hilfen

Delos

Ausguck

Beiträge: 72

Registrierungsdatum: 12. Juni 2019

  • Nachricht senden

142

Mittwoch, 16. Juni 2021, 16:19

Dazu noch von mir eine Nachfrage.
Bisher hatte ich jedesmal das Update vom Mod-Editor neu heruntergeladen, entpackt, den alten gelöscht
und den neuen installiert. Dieses erscheint mir eigentlich sehr mühsam, da ja alle Naselang ein Update erscheint, was auch sehr erfreulich ist. Danke an dieser Stelle dafür.
Muß man das, oder so wie Lenania es beschrieben hat, durchführen? Ich bin mir darüber nicht so ganz schlüssig.
Dann noch eine Frage zu der ständing erscheinenden Warnung vom Win-Defender:
Erkannt:Trojan Script/Phonzy.A!ml
Details: Dieses Programm ist gefährlich. Es führt Befehle eines Angreifers aus.
containerfile: C:\Users\Detlef\Desktop\ModTool210607_full.7z
Betroffene Elemente:
file: C:\Users\Detlef\Desktop\ModTool210607_full\ModTool\AssetExtractor.exe

Lenania

Steuermann

Beiträge: 159

Registrierungsdatum: 12. Juli 2019

  • Nachricht senden

143

Mittwoch, 16. Juni 2021, 16:32

Meine eset Internet Security meldet sich nicht.

Lenania

Steuermann

Beiträge: 159

Registrierungsdatum: 12. Juli 2019

  • Nachricht senden

144

Mittwoch, 16. Juni 2021, 16:39

Hab zum Spaß mal ein Item für den Besucherhafen erstellt. Sollte +500% Besucher generieren. Als Basis hab ich die "Fremdenführerin" genommen.


Erstes Problem war das die bei Eli Bleackworth nicht auftauchte sondern erst beim guten alten Archibald Blake. Und das zweite siehe BIld
»Lenania« hat folgendes Bild angehängt:
  • Anno-Luise.jpg

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

145

Mittwoch, 16. Juni 2021, 17:12

Das mit dem Virus ist ein Problem von AutoIt, damit baue ich das Tool. Die exe-Dateien geben ne Warnung... Den Extractor kann du löschen, den brauchts nicht. Spezielle Einstellungen beim Kompilieren lassen die Warnung verschwinden, das hab ich beim Extractor glaube ich nicht gemacht, daher die Warnung.


Da ich des öfteren im EditorFiles Ordner Dinge ändere, hat das Belassen der alten Dateien Nachteile, z.B. würden dann Objekte im Import-Dialog auftauchen, die da nicht sein sollen. Die Unterordner repräsentieren zum Teil die Dateien, die man angeboten bekommt... EditorFiles würde ich also vor einem Update löschen. Der Rest ist egal.

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

146

Mittwoch, 16. Juni 2021, 18:49

@Lenaia
Ja, hast nen bug gefunden. Bei der Besucher-Einstellung hatte ich nen Tippfehler.... Wird korrigiert.

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

147

Mittwoch, 16. Juni 2021, 19:09

Das Problem mit der laaangen Zeile, die er im Spiel bei dir ausgibt, ist ein weiterer Bug, und zwar werden unter 'Vorfälle' zwei Felder nicht gelöscht beim Import. Kannst du beobachten, wenn du da was einträgst bei Mobilisierungsdingens, dann bleiben die Einträge, auch wenn du ein neues Item lädst. Das geht natürlich so nicht. Mach ich nachher...So ists besser, oder?

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

148

Mittwoch, 16. Juni 2021, 19:18

Ah egal, ich hab (nur bei google drive) einen PATCH für Lenaias Problem hochgeladen.
Das 'richtige' Update folgt später. Lenaia, sei so gut, teste das mal und sag Bescheid.

Lenania

Steuermann

Beiträge: 159

Registrierungsdatum: 12. Juli 2019

  • Nachricht senden

149

Mittwoch, 16. Juni 2021, 21:01

Ein guter Fehler lässt sich reproduzieren ;)
»Lenania« hat folgendes Bild angehängt:
  • Anno-Luise-Neu.jpg

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

150

Mittwoch, 16. Juni 2021, 21:57

Äh, ja... Du musst die Zahlen hier rausnehmen. Die Einträge waren noch drin, sieht man auch an dem Text der ausgegeben wird


ToolOneHelper IncidentResolver... Das ist dann der Fall, wenn du dort Zahlen stehen hast, als Target aber kein Krankenhaus, Polizei oder Feuerwehr gewählt ist.
Mit dem Patch werden auch diese Felder bei Neu-Import zurückgesetzt, hatte ich vorher vergessen.

Beiträge: 93

Registrierungsdatum: 9. Februar 2021

  • Nachricht senden

151

Mittwoch, 16. Juni 2021, 23:48

stimmt danke noch mal ich dachte das diese eigenschaft erst später einbauen willst da hast mich überrascht

ps bei machne "importen" bug es herum beispiel ist lehmgrube aus der neue welt da wird nicht alles gezeigt
  Berater von Fishboss

aktiv in Mod Community ob tester idee beratung oder hilfen

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

152

Donnerstag, 17. Juni 2021, 00:48

Oha, danke! Da bist du auf was Heftiges gestoßen. ALLE Assets mit BaseAsset haben dieses Problem. :aua: Ist aber leicht behoben, denke ich.

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

153

Donnerstag, 17. Juni 2021, 04:40

Ich mach ab jetzt BASE-Versionen.
Dann gibts bei größeren Änderungen ein neues BASE-Update, ansonsten kleine Patches, die über den letzte BASE drübergebügelt werden können.
In dieser ersten BASE ist folgendes neu:
Der Bug von Lenania (siehe paar Posts zurück...)
BETA vom neuen Farm-Felder-Editor zum Anpassen der Feld-Regionen
Paar andere Kleinigkeiten

Beiträge: 93

Registrierungsdatum: 9. Februar 2021

  • Nachricht senden

154

Donnerstag, 17. Juni 2021, 10:11

k
Ich mach ab jetzt BASE-Versionen.
Dann gibts bei größeren Änderungen ein neues BASE-Update, ansonsten kleine Patches, die über den letzte BASE drübergebügelt werden können.
In dieser ersten BASE ist folgendes neu:
Der Bug von Lenania (siehe paar Posts zurück...)
BETA vom neuen Farm-Felder-Editor zum Anpassen der Feld-Regionen
Paar andere Kleinigkeiten



kling interresant
  Berater von Fishboss

aktiv in Mod Community ob tester idee beratung oder hilfen

Delos

Ausguck

Beiträge: 72

Registrierungsdatum: 12. Juni 2019

  • Nachricht senden

155

Donnerstag, 17. Juni 2021, 11:43

Moin Pogo,
Danke für die Info

Beiträge: 93

Registrierungsdatum: 9. Februar 2021

  • Nachricht senden

156

Donnerstag, 17. Juni 2021, 13:15

kleine anliegen.

wenn ich etwas fertig erstellt habe und dann erzeugen möchte dauert es bis der pop-up fenster da ist ca 2 bis 3min (gefühlt). kann man es irgendwie mit ein warte fenster bzw "erzeug fenster" mit lade balken hinrichten das die wartezeit ein bisschen "verschönen" kann?
  Berater von Fishboss

aktiv in Mod Community ob tester idee beratung oder hilfen

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

157

Donnerstag, 17. Juni 2021, 14:14

Potztausend!

2-3 Minuten? Ok,gefühlt, aber trotzdem.
Wie viele Mods hast du in new_mods, wie viele im Anno-Mod-Ordner?
Kann eig. nur daran liegen... Ich habe hier 10-20 Mods gleichzeitig und es dauert max 3 Sekunden!


Hast du alles auf SSD?
Edit: Und es gibt doch den "Mod-Rescan"-Ladebalken, der beim Export kommt...?

Lenania

Steuermann

Beiträge: 159

Registrierungsdatum: 12. Juli 2019

  • Nachricht senden

158

Donnerstag, 17. Juni 2021, 14:36

2-3 Minuten kommt gut hin. Allerdings nur wenn das Tool frisch gestartet ist oder sich nur wenige Mods sich in der Kategorie befinden. Läuft der Client über den Tag Zwecks basteln/testen kann es auch bis zu 10/15min dauern.

pogobuckel

Steuermann

  • »pogobuckel« ist der Autor dieses Themas

Beiträge: 194

Registrierungsdatum: 11. Mai 2021

  • Nachricht senden

159

Donnerstag, 17. Juni 2021, 14:47

Joa... das ist nicht gut. Ab und an mal neu starten, das Tool.
Vielleicht sollte ich doch mal auf c# switchen... Ursprünglich war das ein Versuch von mir, wie weit ich mit AutoIt komme, glaube, mit Code-Optimierung ist da nicht so viel...
Aber dann kam eines zum anderen, das Teil wurde immer größer und größer...

Beiträge: 93

Registrierungsdatum: 9. Februar 2021

  • Nachricht senden

160

Donnerstag, 17. Juni 2021, 15:16

Potztausend!

2-3 Minuten? Ok,gefühlt, aber trotzdem.
Wie viele Mods hast du in new_mods, wie viele im Anno-Mod-Ordner?
Kann eig. nur daran liegen... Ich habe hier 10-20 Mods gleichzeitig und es dauert max 3 Sekunden!


Hast du alles auf SSD?
Edit: Und es gibt doch den "Mod-Rescan"-Ladebalken, der beim Export kommt...?


ja auf C: SSD 1tb
da habe ich nur 3 mods erstellt

in anno ordner sind es ca über 100 mods installiert

"Mod-Rescan"? nicht das wusste kannst mir den screenhot erstellen oder mir zeigen? bin überfragt
  Berater von Fishboss

aktiv in Mod Community ob tester idee beratung oder hilfen