You are not logged in.

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

41

Friday, May 28th 2021, 2:56pm

OK, was meinst du mit Versorgungsweg? Kannst mal geneauer beschreiben, wo dein Problem liegt?

Ich muss jetzt noch was arbeiten, aber heute abend stehe ich wieder zur Verfügung...

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

42

Friday, May 28th 2021, 3:28pm

Als Versorgungsweg hab ich jetzt die Reichweite der Farm/Fabrik zum Lagerhaus genannt.


Hier als Bsp. die neuen Farmen gegenüber den Originalen. Der Unterschied ist deutlich zu sehen.
Lenania has attached the following images:
  • Anno-Versorgungsweg Edit.jpg
  • Anno-Versorgungsweg ORG.jpg

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

43

Friday, May 28th 2021, 4:13pm

[Bug] ?

Bei einer neuen Fabrik wird das Icon in der Produktionsübersicht nicht angezeigt. Da ist nur ein schwarzes Feld.

AdmiralGad

Deckschrubber

Posts: 25

Date of registration: Jan 4th 2021

  • Send private message

44

Friday, May 28th 2021, 5:28pm

Zitat

[Bug] ?
Sowas kenne, wenn eine falsche oder nicht vorhandene GUID eingefügt wird.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

45

Friday, May 28th 2021, 5:39pm

Die Fabrik wird mit der Einstellung nicht angezeigt. Sie erscheint auch nicht wenn 160 Arbeiter in der Siedlung leben. Stelle ich auch "Immer aktiv, keine Bedingung" wird sie richtig angezeigt. Der Fehler mit dem fehlenden Icon besteht aber weiterhin.
Lenania has attached the following image:
  • Anno-Fischbrötchen-Fabrik.jpg

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

46

Friday, May 28th 2021, 10:50pm

So, ich glaube, ich hab dein Problem gefunden. Eigentlich ist es meines...
In der Datei AssetEditor.au3 in Zeile 8783 habe ich </template> statt </Template> geschrieben....
Blöder Bug. Du hast Fischbrötchen (geile Idee... :D) als neues Produkt eingeführt.... Genau das wird wegen des Fehlers nicht erkannt.
Ich schieb nachher ein Update nach, kannst es ja bis dahin selbst in Ordnung bringen... Schwarze Icons gibts eigentlich nur, wenn, wie mein Vorredner schon gesagt hat, wenn mit den GUIDs was vermurkst ist...
Ich hab deine Produktionskette nachgebaut, und nachdem ich die Template-Sache ausgebügelt hatte, gabs keine Probleme mehr...

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

47

Saturday, May 29th 2021, 4:32am

So die Trigger sind gefixt. Als kleinen Bonus gibts jetzt noch einen neuen Trigger zu Auswahl: Unlocked
Das heißt, dein Objekt wird verfügbar, sobald ein anderes verfügbar ist. Das macht einiges leichter, finde ich.
Außerdem gibts wieder eine Menge Bugfixes.
Ich habe die Fischbrötchendingens nachgebaut, funzt jetzt alles. Mit Umlauten, meine ich, macht der modloader manchmal Zicken, deshalb werden jetzt auch die Namen der Mod-Pakete angepasst.
Wichtig: Den alten ModTool Ordner vorher löschen, oder wenigstens die last*.* Dateien im .\res Ordner. Alte Projekte MÜSSEN nicht unbedingt kompatibel sein. Ich werde ab jetzt mehr darauf achten, dass sie kompatibel bleiben.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

48

Saturday, May 29th 2021, 11:56am

Ich hab alles nochmal neu gemacht in der Hoffnung das ich jetzt endlich die Fabriken erstellen kann. Aber leider habe ich immer noch das Problem das die nicht im Menu angezeigt werden, bis auf den Schnapsbrenner. Die Mods funktionieren aber weil die bisher gebauten Gebäude die neuen Einstellungen übernommen haben.


Zudem ist mir folgendes aufgefallen:
- Schnapsbrenner wird mit Arktis geladen obwohl der Import für die alte Welt ist. Das könnte auch erklären warum er als einzigste Fabrik (Sägewerk, Weberei, Schnapsbrenner, Fischbrötchen-Fabrik) funktioniert
- Fischereien lassen sich im Hafen nicht verschoben. Es ist alles rot hinterlegt
- Die Fischbrötchen-Fabrik erscheint nicht mit einer Bevölkerungsvoraussetzung
- Die Wege für die Lastkarren sind noch ca 1/4 vom Originalen
Lenania has attached the following images:
  • Anno-Schnapsbrenner.jpg
  • Anno-Fischerei.jpg

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

49

Saturday, May 29th 2021, 2:04pm

Ich glaube, deine Probleme mit den Versorgungswegen hängt mit einem anderen Mod zusammen, weil ich

a) die Probleme nicht habe
b) mit den Versorgungswegen überhaupt nichts ändere, also ÜBERHAUPT nichts
Welche Mods hast du noch laufen? Alle kompatibel mit der neuen Spielversion?
Bei mir funktionieren auch die Fabriken jetzt. Auch mit Bevölkerungslimit. Mit den Triggern ist das sone Sache, Wenn die einmal augelöst haben, und du lädtst einen Spielstand, wo das passiert ist, macht ein hinterher geänderter Trigger NICHTS mehr.

Entweder alten Spielstand laden oder neue GUID für den Trigger erzeugen.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

50

Saturday, May 29th 2021, 3:06pm

So, bin jetzt einen Schritt weiter.


Das Problem mit den nicht vohandenem Baumenu ist geklärt. Mich hat da der "falsche" Schnapsbrenner auf die richtige Spur gebracht. Wenn eine vorhandene Fabrik geändert wird darf im Feld für den Menueintrag kein Entrag sein. Es wird ja keiner ersetzt oder neu eingebaut.

Das Problem mit dem Trigger ist jetzt auch gelöst, hat funktioniert.


Ausser einem Mod damit ich überall bauen kann nutze ich zum basteln keinen anderen.


Das Problem mit den Versorgungswegen besteht weiterhin. Die sind so völlig unbrauchbar. Vielleicht hast Du ja einen Tipp wie ich die im Mod selber verlängern kann.


Bestehendes Problem:

- Neue Fischerhütten (wenn verändert) könne im Hafen nicht gebaut werden. Der gesamte Hafenbereich wird blockiert.


[Edit]

Fischereien können nach der Veränderung auf Land gebaut werden aber nicht mehr im Hafen.

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

51

Saturday, May 29th 2021, 3:47pm

Ja, das ergibt Sinn. Gibt ne Einstellung, ob an der Küste gebaut werden kann oder an Land, diese berücksichtige ich bis jetzt nicht, ist aber geplant.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

52

Saturday, May 29th 2021, 3:59pm

Hast Du einen Tipp zu der Reichweite der Gebäude?


Bei Hafenmeister, Handelskammer und Rathaus gibt's einen Mod der die Reichweite vergrößert.

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

53

Saturday, May 29th 2021, 4:29pm

Ich kann iwie gar nicht glauben, dass das an mods liegt, die mit meinem Tool erstellt werden, aber ich gucks mur mal an.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

54

Saturday, May 29th 2021, 4:33pm

Ich hab jetzt andere Mods nachgeladen um alles wieder so einzurichten wie sonst. Komischerweise ist das Problem jetzt behoben.

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

55

Saturday, May 29th 2021, 5:05pm

Ist das so korrekt das das Bild vom Fischbrötchen im Inventar so groß ist und nicht mit dem kleinen Icon verbunden ist?
Lenania has attached the following image:
  • Anno-Fischbrötchen-Inventar.jpg

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

56

Saturday, May 29th 2021, 9:31pm

Die Icons sollten 128x128 Pixel groß sein.... Wie groß ist deines? :lol:
Ich konnte dein Reichweitenproblem reproduzieren, hab auch schon ne Idee...

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

57

Saturday, May 29th 2021, 11:41pm

So, hier die Lösung deines Reichweitenproblems. Die Produktionszeit beeinflusst die Reichweite direkt. Du hattest 5 eingestellt, daher war dein Weg kurz. Erhöhe statt dessen lieber die 'min' produktionsrate...

Längere Produktionszeit = längere Versorgungswege
also kein bug :)

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

58

Sunday, May 30th 2021, 10:39am

Danke für den Tipp.


Das Bild ist 128*85 groß. Hab es extra auf die Größe laut Anweisung verkleinert.

pogobuckel

Ausguck

  • "pogobuckel" started this thread

Posts: 88

Date of registration: May 11th 2021

  • Send private message

59

Sunday, May 30th 2021, 2:50pm

Nee, hast du nicht. Es muss wohl quadratisch sein. Ich hatte das noch nie, so wie das bei dir aussieht, aber das kann nur an der falschen Ratio liegen. 128x128 also, nicht 128x85...

Lenania

Ausguck

Posts: 96

Date of registration: Jul 12th 2019

  • Send private message

60

Sunday, May 30th 2021, 3:17pm

Ich hab es neu gemacht. Das Format nimmt Anno und fügt es überall richtig ein. Es war wohl beim verkleinern zu einem Fehler gekommen.


Die Produkte werden jetzt gleich nach dem Level Up im Warenhaus angezeigt. Auch wenn es im Baumenu noch nicht vorhanden ist. Ist jetzt nicht das Problem aber war das so gewollt?

[EDIT]

Erledigt. Hatte falsche Einstellungen, alten Spielstand und den Cacheordner nicht gelöscht




Ich vermisse die Lehmgrube und die Bergwerke in der ladbaren Farmen/Fabriken. Hast Du die nicht dabei oder hab ich was übersehen?