You are not logged in.

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

61

Thursday, January 23rd 2020, 1:31pm

Achja stimmt hast du mir mal erzählt :wedel: ja dann werde ich wohl Version 1.2.2 machen müssen :lol:

DerUpsi

Steuermann

Posts: 156

Date of registration: Jan 23rd 2020

  • Send private message

62

Thursday, January 23rd 2020, 4:26pm

Quoted

"Achja stimmt hast du mir mal erzählt :wedel: ja dann werde ich wohl Version 1.2.2 machen müssen :lol:"
Super! :thumbup: Hab eben auch kurz Anno mit dem Update von heute angespielt, scheinen alle Mods noch zu funktionieren soweit ich das gesehen hab

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

63

Tuesday, January 28th 2020, 10:07pm

Bei meinem Spielstand scheint dieses Mod (Version 1.21) den KI Aufstieg über Handwerker hinaus verhindert zu haben. (Ich spiele mit 4 KI, 2 schwer, 2 medium, eine davon hinzugefügt über AI Schiffswerft).

Die KI stagnierten alle über lange Zeit auf der Stufe Handwerker, aber sofort nach
Deaktivierung des Mods haben zwei der KI binnen Minuten begonnen Ingenieure anzusiedeln, eine dritte folgte wenig später.

Ebenso vermag ich nicht zu
sagen, was genau das Problem an dem Mod ist, das den KI Aufstieg
verhindert, aber dass es etwas mit zusätzlichen Bedürfnissen zu tun
haben könnte, erscheint zumindest logisch.

Ich kann gerne testen helfen, wo das Problem liegt. Im übrigen würde ich das Mod natürlich gerne weiter nutzen (aber sich vernünftig entwickelnde KI Gegner sind mir wichtiger im Zweifelsfall).

Wäre es vielleicht möglich und nicht zu viel Mühe für den Autor dieses tollen Mods (schleim), zumindest das Alte Rathaus und den Kaiserdom als "stand alone" Mods zu bekommen, ohne die anderen Gebäude und neuen Bedürfnisse?

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

64

Wednesday, January 29th 2020, 7:33am

Ok wieder was neues. Ich bezweifle, dass es an den Bedürfnissen liegt, denn den mod gibt es schon einige Monate und du bist die erste Person, die diesen bug hat. Ich denke eher es liegt an etwas neuem. Ich wollte den ki Spielern beibringen, dass diese auch den Dom bauen sollen
Kann sein, dass diese Zeilen den bug verursachen. Werde heute 1.2.2 freigeben da würde ich dich bitten dann nochmal zu testen.

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

65

Wednesday, January 29th 2020, 9:03am

Guten Morgen, werde ich gerne testen, danke für die schnelle Antwort.

Allerdings verwende ich Old Town bereits seit der Zeit vor dem Hinzufügen des Kaiserdoms (den gibt es ja noch nicht allzu lange, ich denke ich habe die meiste Zeit mit Version 1.1 gespielt) und die KI hat gefühlt eine sehr lange Zeit auf Handwerker Stufe verbracht.
Ich habe eben noch einen kurzen Test mit 1.1 und dann noch 1.0 durchgeführt und die KI steigt nicht auf in beiden Fällen, nach Deaktivieren des Mods bei gleicher Savegame wieder direkt Aufstieg zu Ingenieuren.

Könnte es nicht vielleicht auch sein, dass das Mod vor allem von Schönbauern verwendet wird, die ohne KI Gegner spielen und dass es deswegen bisher noch niemandem aufgefallen ist? Oder dass es sich bei vielen um lang laufende Spiele handelt, bei denen die KI bereits längst aufgestiegen war, bevor das Old Town Mod hinzukam?
(Falls es relevant ist: Mein Spiel wurde kurz nach Release von DLC3 gestartet (also Mitte Dezember etwa) und ist mit allen 3 DLC plus Anarchist.)

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

66

Wednesday, January 29th 2020, 9:28am

Ok könntest du mir mal einen Spielstand schicken, wo die ki noch bei Handwerkern feststeckt? Wäre super da könnt ich da mal schauen was da genau schief läuft

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

67

Wednesday, January 29th 2020, 7:12pm

Hab dir ne PM mit Link zum Spielstand geschickt, sag bescheid, wenn etwas nicht funktioniert.

DerUpsi

Steuermann

Posts: 156

Date of registration: Jan 23rd 2020

  • Send private message

68

Thursday, January 30th 2020, 10:18am

Quoted

Könnte es nicht vielleicht auch sein, dass das Mod vor allem von Schönbauern verwendet wird, die ohne KI Gegner spielen und dass es deswegen bisher noch niemandem aufgefallen ist?
Ich spiele zwar als "Schönbauer" aber mit zwei KI Gegnern und dem Anarchisten. Hab das Problem weder bei einem älteren Save-Game noch bei einem neuen, das ich nach dem letzten Update im Januar begonnen habe.

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

69

Thursday, January 30th 2020, 12:11pm

Ich spiele zwar als "Schönbauer" aber mit zwei KI Gegnern und dem Anarchisten. Hab das Problem weder bei einem älteren Save-Game noch bei einem neuen, das ich nach dem letzten Update im Januar begonnen habe.
Ich habe mal bei taubenangriff (Nale) um Expertise gebeten. Wir sind eher der Meinung, dass das Problem auch von dem Mod Harbor_life her rühren könnte (wurde im Spielstand von Kara42 verwendet). Da dieser Mod ziemlich viel an der KI rumwerkelt.
Steht aber noch nix fest! Es muss noch geklärt werden warum es nach Deaktivierung von Old-Town bei Kara42 es auf einmal ging.

Das merkwürdige ist auch, dass bei Kara42's Spielstand die KI auch in der neuen Welt nicht zu Obreros aufsteigen, obwohl mein Mod rein garnix bei den Obreros hinzufügt oder entfernt

Deine Erfahrung unterstützt aber meine These, dass mein Mod sauber ist :D

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

70

Thursday, January 30th 2020, 12:59pm

Das mit den Obreros war mir nicht Mal aufgefallen bisher. Wenn ich nach Hause komme, kann ich ja Mal testen Old Fön rauszulassen und Hat Ohrlife zu deaktivieren. Es scheint ja evtl dann ein Zusammenspiel beider Mods zhu sein? Denn die Deaktivierung von Old Fön brachte Abhilfe i. Der alten Welt zumindest, neue habe ich nicht Mal
beobachtet bisher.

nordstern84

Meereskenner

Posts: 697

Date of registration: Jul 11th 2016

  • Send private message

71

Thursday, January 30th 2020, 5:03pm

Obreros haben aber keine separaten Werte. Also sie haben separate Bedürfnisse aber z.b. Einwohnerzahl, etc werden vom normalen Arbeiterhaus übernommen, ebenso wie vom Bauernhaus die Basispops.
  Ich bin Legastheniker.

Wer also Rechtschreibfehler oder unklare Formulierungen findet, soll bitte versuchen die Grundaussage zu verstehen oder darf sie gerne behalten :)

Danke für euer Verständnis.

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

72

Thursday, January 30th 2020, 8:28pm

So, ich habe mal Harbourlife deaktiviert, Old Town aktiviert und eine Weile auf max. Geschwindigkeit laufen lassen - kein Aufstieg der KI über Handwerker bzw. Journaleros hinaus.
Nach Deaktivieren von Old Town das vorher berichtete Bild: KI steigen direkt zu Ingenieuren auf und eine ganze Weile später auch zu Obreros in der neuen Welt. (Könnte es sein, dass der mangelnde Obrero Aufstieg nur ein Symptom der Stagnation auf Handwerker ist? Steigen die normal auf, bevor die alte Welt bei der jeweiligen KI Ingenieure erreicht hat?)
PS:

Wäre es in Ordnung, wenn ich versuche, mir eine Variation von Old Town zu basteln, die nur das Alte Rathaus und den Kaiserdom enthält?

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

73

Thursday, January 30th 2020, 9:54pm


So, ich habe mal Harbourlife deaktiviert, Old Town aktiviert und eine Weile auf max. Geschwindigkeit laufen lassen - kein Aufstieg der KI über Handwerker bzw. Journaleros hinaus.
Nach Deaktivieren von Old Town das vorher berichtete Bild: KI steigen direkt zu Ingenieuren auf und eine ganze Weile später auch zu Obreros in der neuen Welt. (Könnte es sein, dass der mangelnde Obrero Aufstieg nur ein Symptom der Stagnation auf Handwerker ist? Steigen die normal auf, bevor die alte Welt bei der jeweiligen KI Ingenieure erreicht hat?)
PS:

Wäre es in Ordnung, wenn ich versuche, mir eine Variation von Old Town zu basteln, die nur das Alte Rathaus und den Kaiserdom enthält?
Ich bin grad dabei einen eigenen Spielstand zu testen nur mit Old-Town aktiv um zu sehen was passiert mit der KI.

Solange es sich in privaten Kreisen bewegt ist mir das völlig egal.

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

74

Friday, January 31st 2020, 6:07pm

Old-Town v1.2.2

Also ich muss Kara42 leider recht geben. Es lag wirklich an Old-Town.

Zur Erklärung: Die KI konnte nicht zu Ingenieuren aufsteigen, da sie immer wieder versucht hat statt ihre Handwerkshäuser aufsteigen zu lassen, die neuen Wohnhäuser von Old-Town zu bauen. Das kann allerdings zu diesem Zeitpunkt des Spiels nicht funktionieren. Dank taubenangriffs (Nales) Hilfe konnte ich der KI jetzt mitteilen, dass sie nicht mehr anfragen soll, ob sie die neuen Wohnhäuser bauen darf.

Außerdem habe ich auch den Bug behoben, dass man nur noch die neue Kirche bauen konnte und nicht mehr zur alten wechseln konnte.

Download:

GDrive

Ich muss mich auch bei dem Ersteller von Harbor-Life entschuldigen, da ich den Fehler seinem Mod erst unterjubeln wollte. Sorry! :fleh:


Und danke An Kara42, dass er so hartnäckig geblieben ist und mich drauf aufmerksam gemacht hat :thumbsup:

Kara42

Deckschrubber

Posts: 22

Date of registration: Jun 9th 2019

  • Send private message

75

Friday, January 31st 2020, 7:24pm

Hey, nichts zu danken, jetzt kann ich mein Spiel mit dem kompletten Mod fortsetzen :jaaaaa:

WalGier

Steuermann

Posts: 155

Date of registration: Jan 27th 2019

  • Send private message

76

Saturday, February 1st 2020, 9:47am

Hallo fishboss,

ich weiß nicht, ob es relevant ist (weil das Spiel heute zum ersten Mal abgestürzt ist), aber ich setze mal die Meldung aus dem Logfile hier rein. Ist heute erschienen nach dem Update auf Version 1.2.2.

[2020-02-01 09:02:27.385] [warning] Speculative path lookup failed Values/ItemEffectTargetPool/EffectTargetGUIDs/Item[GUID='1010347' (GUID=192446) in F:\Anno 1800\mods\[Addon] Old-Town\data\config\export\main\asset\assets.xml: Expected ']' to match an opening '['. Please create an issue with the mod op that caused this! Falling back to regular 'slow' lookup.
[2020-02-01 09:02:27.592] [warning] Speculative path lookup failed Values/ItemEffectTargetPool/EffectTargetGUIDs/Item[GUID='1010365' (GUID=190136) in F:\Anno 1800\mods\[Addon] Old-Town\data\config\export\main\asset\assets.xml: Expected ']' to match an opening '['. Please create an issue with the mod op that caused this! Falling back to regular 'slow' lookup.
[2020-02-01 09:02:27.756] [warning] Speculative path lookup failed Values/PopulationLevel7/PopulationInputs/Item[Product='1010356' (GUID=15000003) in F:\Anno 1800\mods\[Addon] Old-Town\data\config\export\main\asset\assets.xml: Expected ']' to match an opening '['. Please create an issue with the mod op that caused this! Falling back to regular 'slow' lookup.
[2020-02-01 09:02:28.584] [warning] No matching node for Path //Asset[Values/Standard/GUID='190781']/Values/ItemEffectTargetPool/EffectTargetGUIDs/Item[GUID='1010346'] in [Addon] Old-Town (data\config\export\main\asset\assets.xml:2071)

fishboss

Freibeuter

  • "fishboss" started this thread

Posts: 327

Date of registration: Jun 7th 2019

  • Send private message

77

Saturday, February 1st 2020, 1:17pm

Hallo WalGier,

ich würde behaupten diese Fehlermeldungen sind eher eine Folge des Absturzes und nicht die Ursache. Wenn Anno abschmiert kann es schon mal sein, dass er den Mod für ein paar Millisekunden nicht mehr richtig liest.

Was anderes ist es natürlich wenn das Spiel dauernd abstürzt und immer wieder dieselben Fehlermeldungen kommen. Aber ich hoffe das war jetzt ein einmaliger Vorfall oder?

Wenn dem so ist würde ich dem vorerst keine größere Bedeutung zusprechen.

WalGier

Steuermann

Posts: 155

Date of registration: Jan 27th 2019

  • Send private message

78

Saturday, February 1st 2020, 3:59pm

Spiel läuft wieder stabil (habe den Cache mal wieder geleert) mit OldTown 1.2.2 - hat sich wohl ein wenig "verschluckt".
Das Logfile wollte ich einfach nur mitteilen für den Fall, daß anderweitig ebenfalls Probleme auftreten sollten.
Ist ja manchmal hilfreich - aber du kennst die Möglichkeit der Fehlersuche sicher schon.

Auch von meiner Seite ein Riesenkompliment für die großartige Arbeit deinerseits.
Vielen vielen Dank dafür.

nordstern84

Meereskenner

Posts: 697

Date of registration: Jul 11th 2016

  • Send private message

79

Saturday, February 1st 2020, 5:26pm

Kann passieren. Bei mir ist Anno gestern auch abgestürzt als ich Pläne zu Gebäuden aufgewertet habe. Und garnicht mal soviele... Passiert... aber eher selten. Beobachte einfach mal ob es öfters passiert. Wenn es an nem Mod liegt, ist der Fehler idR häufig vorhanden und reproduzierbar. Ansonsten liegt der Verdacht nahe das es sich um ein Problem des basisspiels handelt.
  Ich bin Legastheniker.

Wer also Rechtschreibfehler oder unklare Formulierungen findet, soll bitte versuchen die Grundaussage zu verstehen oder darf sie gerne behalten :)

Danke für euer Verständnis.

chris1

Frisch Angeheuert

Posts: 2

Date of registration: Feb 14th 2020

  • Send private message

80

Friday, February 14th 2020, 12:41pm

Bei mir funktioniert die OldTown-Mod nicht. "Bei Ingenieuren kommt das Bedürfnis Höhere Kultur hinzu, welches durch das Schauspielhaus gestillt wird." Ist nicht da auch die Altstadt-Prachtbauten:- freigeschaltet bei 1500 Ingenieuren tauchen nicht auf. Ich nutze die Version 1.2.2

2 users apart from you are browsing this thread:

2 guests