You are not logged in.

seb4stian89

Leichtmatrose

  • "seb4stian89" started this thread

Posts: 13

Date of registration: Feb 11th 2018

  • Send private message

1

Sunday, March 31st 2019, 8:56am

Mauszeiger Scrolling Problem

Hallo liebe Leute,

ich habe mir einen neuen PC zugelegt und gleich Anno per Steam installiert. Ich habe allerdings nun das Problem, dass das automatische Scrolling am Bildschirmrand nur oben und links funktioniert. Rechts und unten funktioniert es nur wenn man ganz langsam Richtung Bildschirmrand wandert und bei einem bestimmten Punkt innehält. Wenn man direkt gegen den Rand fährt, passiert gar nichts.

Wie folgt habe ich installiert:

1. Steam Anno + Update 1.3
2. Steam Venedig + Update 2.01
3. IAAM 4.3
4. > 2GB Häcken mit Explorer Suite gesetzt
Bis zum Schritt 4 funktioniert alles einwandfrei. Es halt also etwas mit dem Verändern der .exe auf >2 GB zu tun. Allerdings frage ich mich warum, das ändert doch nichts an den Bildschirmeinstellungen bzw. Aufstellungseinstellungen. Der Fehler ist auch umkehrbar: Häckchen weg und es funktioniert wieder.

Das Spiel ist im Vollbild und Scrolling ist aktiviert. Eine Veränderung der Auflösung hat nichts gebracht.

Vielleicht könnt ihr mir helfen.

Liebe Grüße

Soricida

Meereskenner

Posts: 694

Date of registration: Dec 30th 2011

  • Send private message

2

Sunday, March 31st 2019, 10:27pm

Hallo sebvierstian

ich habe weder Steam, noch den mehr als 2GB (Patch).
Diesen so genanten 4GB-Patch braucht man doch erst, wenn man einen
größeren Spielstand erreicht hat und Anno dann "Speicher voll" meldet.
Geht das scrollen denn, wenn Du Anno unter "Optionen" in den "Fenstermodus" schaltest?
Welche Einstellung hast Du in Windows > Systemsteuerung > Anzeige?
Bei einigen anderen Einstellungen als 100% gab es auch mal Probleme mit... ???

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

seb4stian89

Leichtmatrose

  • "seb4stian89" started this thread

Posts: 13

Date of registration: Feb 11th 2018

  • Send private message

3

Monday, April 1st 2019, 6:15pm

Hallo Soricida,

Mit Scrollen meine ich nicht heran- und herauszoomen, sondern am Bildschirmrand das Sichtfeld nach links rechts oben unten bewegen. Das geht im Fenstermodus doch gar nicht.

Bei den Anzeigeeinstellungen habe ich die 100% schon ausprobiert. Das funktioniert leider auch nicht.

Aber wie gesagt, der 4GB Patch ändert doch eigentlich nichts an der Auflösung?!
Grüße
Seb4stian

Admiral Drake

Schatzjäger

Posts: 2,206

Date of registration: Nov 3rd 2004

  • Send private message

4

Monday, April 1st 2019, 6:44pm

Ja - immer dieses "eigentlich" ...
Ich habe mit dem 4GB-Patch keine guten Erfahrungen gemacht. Eigentlich sollte Anno 1404 dann ja über 3GB nutzen können - hat es bei mir aber nicht, dafür waren die Abstürze extrem heftig, teilweise musste ich den ganzen PC neu starten.

Ich würde dir raten, spiele erstmal ohne den, soweit du kommst. Ich hatte über 150.000 EW geschafft, bevor der Speicher alle war ...
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !

seb4stian89

Leichtmatrose

  • "seb4stian89" started this thread

Posts: 13

Date of registration: Feb 11th 2018

  • Send private message

5

Wednesday, April 3rd 2019, 6:15pm

Hey Admiral Drake,

wenn das so wäre, dann würde ich den Patch auch nicht nutzen. Leider kommt bei mir die Meldung bereits nach 5.000 Einwohnern und ca. 30 min Spielzeit.

Da will ich gar nicht wissen, wie es ist, wenn ich 150.000 Einwohner habe...
Gruß
Seb4stian

Admiral Drake

Schatzjäger

Posts: 2,206

Date of registration: Nov 3rd 2004

  • Send private message

6

Wednesday, April 3rd 2019, 7:26pm

Also für das Speicherproblem habe ich so meine eigene Theorie - du kannst es ja mal ausprobieren.
Starte den Rechner neu und achte darauf, dass keine Prozesse automatisch starten, die viel Hauptspeicher fressen.
Dann starte Anno 1404 ganz normal und lade dein Spiel. Schau mal im Task-Manager, wieviel Speicher Anno belegt.
Ich denke, es ist wichtig, dass Anno möglichst viel Speicher unterhalb der 4 GB bekommt. Mit diesem Verfahren bin ich übrhaupt erst so weit gekommen. Anno hat dann ca. 1,2 GB Speicher, vermutlich braucht es den Rest für die Grafik (alle Einstellungen gegen Ende übrigens auf niedrig, das spart noch ein wenig Speicherplatz).
Ob das alles valide ist, weißich nicht, aber bei mir hat es ganz gut funktioniert ...
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !

Soricida

Meereskenner

Posts: 694

Date of registration: Dec 30th 2011

  • Send private message

7

Friday, April 5th 2019, 10:49pm

Ich vermute mal, das Anno auch unter 64Bit-Systemen nur die ersten 2 GB des Speichers verwendet,
(wie bei 32Bit-Systemen) wenn dieser "4GB-Patch" nicht aktiviert wird.
(Jedes Programm das vor Anno geladen [gestartet] wird, verringert darum die Spielzeit!)
Tatsache ist, daß Anno dann aber mit diesem "Patch" nicht mehr die Meldung anzeigt, sondern irgendwann einfach abstürzt!
Schaut Euch mal den Link im ersten Post dort an (Edit: Forum Annothek) > 4 GB Anpassung für Anno 1404 / Venedig
Aber wohin kommt denn nun der "Kernelspace" bei 64Bit-Systemen ???

Hallo Seb4stian,
zwei Ideen habe ich noch...
Vor ein paar Jahren gab es auch ein Mausproblem mit Anno (welches???).
Er hatte zum Glück Seine DxDiag gepostet...
Bei Ihm gab es noch eine "Steuereinheit" (für Auto, oder Flugzeug :scratch: ).
Als Er dessen Stecker zog, war die Maus wieder iO...

Unter dem Link oben, im Beitrag #18 gibt es auch noch ein/zwei Lösungen für andere Steam-Probleme mit dem "4GB-Patch"... :hey:

Wenn das alles bei Dir auch nicht hilft, dann mache bitte mal eine DxDiag von Deinem System hier als Anhang.

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

seb4stian89

Leichtmatrose

  • "seb4stian89" started this thread

Posts: 13

Date of registration: Feb 11th 2018

  • Send private message

8

Wednesday, April 10th 2019, 1:22pm

Hey,

also das Mauszeigerproblem hat sich gelöst. Vielen Dank nochmal für die Hilfe. Im Endeffekt habe ich es in den Griff gekriegt, indem ich die Vollbildoptimierung ausgeschaltet habe.

Leider hab ich das altbekannte "Speicher aufgebraucht" Problem, allerdings in ganz neuer Extremität.

Ich habe einen Spielstand mit ca. 10k Einwohnern (alle noch Siedler). Lade ich diesen ohne CFF Explorer veränderte .exe dann taucht innerhalb der ersten 3 min die Meldung "Speicher ist aufgebraucht" auf. Manchmal sogar direkt nach Spielbeginn.

Lade ich ihn mit veränderter .exe (> 2GB), dann stürzt das Spiel innerhalb der ersten 10 min einfach ab.

Neue Endlosgames liefern anfänglich noch Spielzeiten von 1-2 Stunden, enden aber im gleichen Problem.

Ich habe es mit dem 4GB Patch, dem CFF Explorer und den Exe Dateien aus dem Link von Soricida sowie Neuinstallation versucht. Nichts hilft.

Zur Erinnerung: Steam Anno -> Steam Venedig --> IAAM

Kann man aus meiner Dxdiag was herauslesen?
Grüße
Seb4stian89
seb4stian89 has attached the following file:
  • DxDiag.txt (80.69 kB - 4 times downloaded - latest: Apr 13th 2019, 8:08am)

bergveld

Frisch Angeheuert

Posts: 4

Date of registration: Oct 29th 2018

  • Send private message

9

Wednesday, April 10th 2019, 6:22pm

Moin Seb,

hast du schon mal probiert den Inhalt des FXO-Ordners zu löschen?

Bei meinen "Problemspielen" hat es richtig was gebracht. Der Inhalt wird bei mir beim Windows-Start automatisch gelöscht.

Dafür musst du eine einfache Textdatei erstellen (siehe FXO-Adios.jpg).
Die Datei im Pfad (siehe FXO-Ordner) speichern, eine Verknüpfung anlegen und die z.Bsp. auf dem Desktop speichern zum manuellen Löschen. Die Verknüpfung kann man auch in den Autostart-Ordner von Windows legen, dann wird der Ordnerinhalt bei jedem WIN-Start automatisch gelöscht.

Ich hab damit schon mal 2,5 h geschafft bei einem Spiel das sonst nach 15 - 20 Min. abgeraucht ist, musste allerdings zwischendurch öfters über den Taskmanager den Inhalt des FXO-Ordners löschen. Das ging jedesmal über /STRG/ALT/ENTF in den Taskmanager > FXO-Adios.cmd > zurück zu Anno, ohne dass das Spiel dabei abgestürzt ist.

Kannst ja mal versuchen, wünsch dir viel Erfolg.
bergveld has attached the following images:
  • FXO-Adios.jpg
  • FXO-Ordner.jpg

seb4stian89

Leichtmatrose

  • "seb4stian89" started this thread

Posts: 13

Date of registration: Feb 11th 2018

  • Send private message

10

Thursday, April 11th 2019, 10:54am

Hallo bergveld,
Danke für den Vorschlag. Löst das Problem aber leider auch nicht. Absturz nach 4einhalb Minuten.

Grüße
Seb4stian89