Sie sind nicht angemeldet.

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

1

Samstag, 5. Mai 2018, 21:53

Grafikfehler beim raustabben oder betätigen der Windows Taste

Hallo,

ich habe mir bei "GOG" 1503 gekauft gehabt. Dort wurden die älteren Spiele optimiert, damit sie auch unter neuen Systemen laufen. Wie auch bei 1404 funktioniert 1503 gut. Es gibt keine Abstürze o.ä.
Aber sobald ich im Spiel raustabbe oder die Windows Taste drücke und ich dann wieder in Anno gehe wird das ganze Bild verzogen, der größte Teil des Bildschirms ist rosa/lila und es flackert. Erst bei neustarten des Spiels sieht wieder alles normal aus. Bei 1404 habe ich dieses Problem nicht.

Was kann ich also tun? ?(

Gruß

Dickerbaer

Administrator

Beiträge: 4 419

Registrierungsdatum: 1. Mai 2004

  • Nachricht senden

2

Sonntag, 6. Mai 2018, 10:54

Es wird wohl am Grafikkartentreiber liegen, dazu bräuchten wir eine DXDIAG.
Da das Spiel jedoch ansonsten läuft, schlage ich vor, dass der Fenstermodus genutzt wird.
Ich bin der Meinung, dass damit das Problem nicht auftritt. Wie man diesen Fenstermodus bei Anno 1503 nutzt kann man über die Forensuche herausfinden.
Das dürfte für jemanden der immer wieder die Windows Taste nutzen muss die elegantere Lösung sein.
  Höflichkeit ist die höchste Form der Verachtung!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

3

Sonntag, 6. Mai 2018, 16:27

Erst einmal vielen Dank für die Antwort! Treiber ist aktuell.
Das mit dem Fenstermodus will nicht so ganz klappen. Wenn ich das "/window" anhänge, wird Anno nur oben links angezeigt und der Rest des Bildschirm ist schwarz. Was nun?
Es wird wohl am Grafikkartentreiber liegen, dazu bräuchten wir eine DXDIAG.
Da das Spiel jedoch ansonsten läuft, schlage ich vor, dass der Fenstermodus genutzt wird.
Ich bin der Meinung, dass damit das Problem nicht auftritt. Wie man diesen Fenstermodus bei Anno 1503 nutzt kann man über die Forensuche herausfinden.
Das dürfte für jemanden der immer wieder die Windows Taste nutzen muss die elegantere Lösung sein

Soricida

Piratenschreck

Beiträge: 685

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

4

Sonntag, 6. Mai 2018, 19:14

Hallo Inversible,
willkommen in der AnnoZone

Hast Du " /windows" angehängt?
Habe ich noch nie versucht.
Ich hatte immer den Tip " /w" benutzt.

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

5

Sonntag, 6. Mai 2018, 19:24

Das habe ich auch schon probiert. Es passiert mit dem Befehl genau das gleiche. Hatte es hier raus http://fenstermodus.de/index.php?name=Anno%201503

Soricida

Piratenschreck

Beiträge: 685

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

6

Sonntag, 6. Mai 2018, 20:25

Ist ja interessant, man lernt nie aus...

Schwieriger es ist, Rat zu geben nun, wenn WIN 10 und Anno von Gog man(n) nicht hat. :scratch:

Hast Du bei den Eigenschaften unter
> Verknüpfung > Ausführen - mal die verschiedenen Fenster-Einstellungen versucht?
> Kompatibilität - die 265 Farben, und, oder als Admin ausführen?

Ist Dein aktueller Graphik-Treiber von WIN 10, oder von AMD bzw. Nvidia?

Grübelnd,
grüßt
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

7

Sonntag, 6. Mai 2018, 22:54

Der Nvidia Treiber ist aktuell. Ich versteh es einfach nicht. Das Spiel funktioniert grundsätzlich super. Aber dass ich nicht den Fenstermodus hinbekomme... :keineahnung:

Soricida

Piratenschreck

Beiträge: 685

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

8

Montag, 7. Mai 2018, 22:03

Kann man in der "Nvidia Systemsteuerung" (oder Control Panel?) dazu noch etwas einstellen?
> 3D-Einstellungen verwalten > Programmeinstellungen (gibt es die noch? [ich habe z.Z. AMD])
aber Anno 1503 ist ja eigentlich ein 2D-Programm... :scratch:

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

9

Dienstag, 8. Mai 2018, 14:48

Ja das gibt es noch aber ich glaube nicht dass das was bringt.

Hier mal ein Screenshot. InGame flackert es noch.
»Inversible« hat folgendes Bild angehängt:
  • asdfer.png

Soricida

Piratenschreck

Beiträge: 685

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

10

Dienstag, 8. Mai 2018, 23:23

Bei einigen Graphikproblemen hilft es, wenn man einen Vorgänger des Graphiktreibers installiert.
Die neuen verlassen anscheinend manchmal zu früh den Beta-Status...

Eine andere Idee ist noch der virtuelle Desktop, den hat doch WIN 10 schon bei.
Wie man Anno aber da hinein bekommt? Und ob es dann beim Wechsel nicht mehr flimmert??

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

11

Mittwoch, 9. Mai 2018, 13:36

Am Treiber kann es nicht liegen da es mit dem vorherigen auch schon nicht funktioniert hat. Ich habe irgendwas von einer "virtuellen" Maschine gehört. Vllt hilft das

Nale

Deckschrubber

Beiträge: 24

Registrierungsdatum: 21. Oktober 2017

  • Nachricht senden

12

Mittwoch, 9. Mai 2018, 15:25

Ist ganz normal für die Version. Raustabben sorgt auf Windows 10 für Flackern, habe ich auch das Problem.

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

13

Mittwoch, 9. Mai 2018, 19:25

Ist ganz normal für die Version. Raustabben sorgt auf Windows 10 für Flackern, habe ich auch das Problem.
Echt schade. :(

Soricida

Piratenschreck

Beiträge: 685

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

14

Mittwoch, 9. Mai 2018, 22:11

In einer virtuellen Maschine kannst Du ein älteres (oder neueres) Window (oder Linux) installieren.
Wenn Win 7 oder XP aber länger funktionieren sollen, benötigt man eine "Lizenz"? (oder installiert es jeden Monat neu???)

Bei Win 7 Professional, Enterprise und Ultimate gab es damals (gibt es auch noch) für den "XP Modus"
eine spezielle echte Windows XP Professional in einer virtuellen Maschiene...
(Bei meine Home-Version bewirkte der "XP Modus" nie etwas!)
Gibt es die noch in Win 10, z.B. Enterprise, Education, ...?

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Inversible

Frisch Angeheuert

  • »Inversible« ist der Autor dieses Themas

Beiträge: 8

Registrierungsdatum: 5. Mai 2018

  • Nachricht senden

15

Donnerstag, 10. Mai 2018, 21:07

Ja. Home, Pro, Ultimate usw

Dickerbaer

Administrator

Beiträge: 4 419

Registrierungsdatum: 1. Mai 2004

  • Nachricht senden

16

Donnerstag, 10. Mai 2018, 23:24

Zu uralten Zeiten gab es auch einmal Probleme, z.B mit der Minimap. Damals half es in den Grafikkarteneinstellungen die Anisotrope Filterung und das Antialiasing abzustellen. Vielleicht ist es hier ähnlich.
  Höflichkeit ist die höchste Form der Verachtung!

Glücksritter

Landratte

Beiträge: 1

Registrierungsdatum: 19. Mai 2018

  • Nachricht senden

17

Samstag, 19. Mai 2018, 11:44

Hi,
Ich hab das selbe Problem, bei mir taucht es aber nicht nur beim raustabben auf, sondern auch, wenn eine Cutscene gespielt wird. Also Beispiel:
Ich war (ausnahmsweise mal) ein guter Herrscher und meine Bürger und Kaufleute möchten mir ein Denkmal setzen. Grundsätzlich ne nette Sache, aber da kommt dieser kleine Film mit dem armen Typen der für mich eine Statue aus Gold giesen muss. Und sobald der Film anfängt zu spielen bekomme ich genau den oben beschriebenen Grafik Fehler.
Das ärgerlichste daran ist, dass ich dann eben auch nicht mehr speichern kann. Ich hab's einmal so weit geschafft mich durch diesen schwarzen Balken an der Seite durch zu klicken bis ich das vertraute "Spiel gesichert" gehört habe. Aber der Spielstand war dann trotzdem nicht abgespeichert worden.
Gibt es dazu irgendeine Idee, oder hat noch jemand das Problem?
Besten Dank für alle Antworten

Edit: Ich bin grade bei der Suche im Forum noch auf den Thread gestoßen, der "Videos zerstören saves" oder so heißt. Da ist genau das Problem geschildert das ich auch habe. Nur wurde der Thread geschlossen, weil der betreffende mit RUAMZUZLA die Videos getriggert hat. Das hab ich nicht, aber vielleicht hängt das ja trotzdem zusammen.