You are not logged in.

Client93

Frisch Angeheuert

  • "Client93" started this thread

Posts: 1

Date of registration: Mar 21st 2021

  • Send private message

1

Sunday, March 21st 2021, 9:12pm

Multiplayer lädt zusätzliche Maps nur beim Hoster

Guten Abend liebe Community,

als großer Annofan hat es mich, wie wahrscheinlich auch viele Andere, sehr gefreut, dass Anno 1503 nun auch im Multiplayer spielbar ist.

Was mich weniger gefreut hat ist, dass es nur 4 verschiedene Multiplayerkarten gibt, die allesamt eher mau sind...
Kein Problem habe ich mir gedacht, einfach auf Annopool Mehrspieler Szenarien laden und fertig.
Ein guter Freund der auch großer Fan ist tat es mir gleich.
Maps wie in der Anleitung beschrieben hinzugefügt und los.

Nun zum Problem:
Wenn ich das Spiel erstelle und er beitritt lädt die Map. Ich sehe dann die Karte und ein Fenster, dass er, also mein Mitspieler noch lädt.
Nach einiger Zeit wirft es ihn zurück ins Hauptmenü. Er sieht die Spielkarte gar nie!
Lädt er die Karte sieht er sie nach kurzer Zeit und bei ihm steht, dass es bei mir laden würde. Ich werde ins Menü zurückgeworfen...


Nehmen wir eine "Originalkarte" haut es hin. Ich verstehe es einfach nicht. Andere User berichten das es sehrwohl hinhaut, nach einiger Recherche habe ich einen Gamer mit dem gleichen Problem gefunden, sein Anliegen blieb jedoch unbeantwortet.

Hier erklärt:

https://forums.ubisoft.com/showthread.ph…er-doesn-t-load

Woran könnte das nur liegen? ?( ?( ?(
Ich bitte um Hilfe da wir uns beide schon so auf den Multiplayer gefreut haben!

drkohler

Master of Editor

Posts: 1,577

Date of registration: Jun 18th 2003

  • Send private message

2

Tuesday, March 23rd 2021, 8:07am

Nach solanger Zeit sich noch an die hundert Arten zu erinnern, warum der (Original-)MP nicht startete, ist unmöglich..
Einige der Gründe waren damals:
1. Zu hohe Ping-Werte
2. Ein Bastler, der die BGruppen.dat veränderte
3. Eine Map mit Userinseln
4. Eine Map mit Randominseln, aber der Hoster hatte Eigenbau-Inseln im Inselverzeichnis, welche die Mitspieler nicht hatten
5. Einer der Spieler hat einen Doppelclick gemacht (das war zu jeder Zeit tödlich)

Ich denke Grund 5 wurde sicher gefixed in der History-Edition.

Die Originalszenarien im Verzeichnis 500Multi besitzen alle nur Randominseln. Wenn sie immer laufen, fallen Gründe 1,3,4 weg.
Die Originalszenarien stammen von zwei verschiedenen alten Anno-Versionen ab, macht aber anscheinend nichts. Mit dem Editor kann man ungestraft die Inseln verschieben und/oder durch grössere Inseln ersetzen (da sind wirklich fast nur kleine Inselchen drauf). Wenn man das macht, nicht vergessen der Datei einen anderen Namen zu geben und eine neue GUID generieren im Editor.

Bei Szenarien vom Pool können Userinseln in der Map sein (besonders Annokrat war da immer sehr kreativ). Hier müssen dann alle Spieler Alles richtig installieren und die Dateien scenes.cach und Islands.cach (das sind die Namen, glaube ich) gelöscht werden vor dem Start.

Es gibt noch 9999 andere Gründe, aber das Problem "bei den Anderen geht's und bei mir nicht" ist praktisch unlösbar wenn man's nicht selber macht und es geht auch nicht. Der MP war nie stabil und wenn ich sehe wie wenig für die HE wirklich gemacht wurde, dann erstaunen mich die Probleme nicht. Wobei der MP allerdings immer das gigantische Hauptproblem ist/war.

AyCe

Ausguck

Posts: 80

Date of registration: Sep 6th 2011

  • Send private message

3

Thursday, October 21st 2021, 7:15pm

Habe die Karten genommen die hier empfohlen wurden und bei uns geht es. Bei manchen desynct es zwar nach einiger Zeit, aber laden tut jede.

[HistoryEdition] Ordentliche Multiplayer-Maps

Vielleicht liegts an den Karten?
  1602 is so ANNOying...