You are not logged in.

Sir Henry

Oberbordschrauber

  • "Sir Henry" started this thread

Posts: 1,708

Date of registration: May 24th 2003

  • Send private message

1

Sunday, January 8th 2006, 5:38pm

Anno 1602 stürzt beim Spielen ab

Aus gegebenem Anlass, und weil dieses Problem anscheinend umso häufiger auftritt, je leistungsfähiger die Grafikkarten werden:

Wenn Anno 1602 während des Spiels - vor allem bei Angriffen auf CG oder Piraten - abstürzt, müsst ihr die Hardwarebeschleunigung von Grafik und Sound auf Null drehen. Wie das genau geht, ist in diesem Artikel von Microsoft genau beschrieben (Methoden 4 und 7 nacheinander probieren). Falls das nicht hilft, auch die anderen beschriebenen Methoden ausprobieren.

Beim Laden der Microsoft-Seite kann eine Sicherheitswarnung erscheinen, diese kann getrost mit Nein beschieden werden, wenn man auf die enthaltenen Videos keinen Wert legt.

NEU: Im Annopool gibt es jetzt einen 1602 Launcher, der automatisch die Grafikbeschleunigung anpasst und nach dem Spiel wieder zurückstellt. Die Soundbeschleunigung muss nach wie vor von Hand geregelt werden.
  Cheers, Sir Henry
Schon im Anno-Pool vorbeigeschaut?

This post has been edited 2 times, last edit by "Sir Henry" (May 12th 2007, 10:45am)


FrankB

Boardsmutje

Posts: 953

Date of registration: Dec 14th 2003

  • Send private message

2

Sunday, January 8th 2006, 10:09pm

Die Methode 6 (also die Reduzierung der Hardware-Beschleunigung für den Sound) würde ich in jedem Fall gleich mit der Grafik erledigen. Seitdem ich das mal gemacht hatte, lief Anno erheblich stabiler. :)

Wichtig ist auf jeden Fall, die Grafik auf Null zu reduzieren - auch wenn Microsoft von "zwei Stellen links von Maximal" spricht. Mindestens in einem Fall hat das nämlich überhaupt nicht geholfen - erst bei vollständiger Reduzierung der Hardwarebeschleunigung lief Anno normal.

This post has been edited 1 times, last edit by "FrankB" (Jan 8th 2006, 10:12pm)


Louis

Plankenstürmer

Posts: 31

Date of registration: Dec 27th 2003

  • Send private message

3

Saturday, January 14th 2006, 2:43pm

Ich habe dieses Problem schon sehr häufig gesehen und auch selber erlebt, doch bei mir funktioniert es nur, wenn ich unter Eigenschaften die Kompatibilität auf Windows NT stelle (vorher ist sie auf Win95), bei den meisten hilft auch schon Win98-Kompatibilität. ;)


Louis
  sor far~ :geenau:

FrankB

Boardsmutje

Posts: 953

Date of registration: Dec 14th 2003

  • Send private message

4

Saturday, January 14th 2006, 3:54pm

Der Kompatibilitätsmodus sollte unter WinXP eigentlich gar nicht eingeschaltet sein - egal ob für Win98 oder NT. Das heißt natürlich nicht, daß es nicht doch vielleicht helfen könnte (besonders in der US-Version), aber in den meisten Fällen ist es eben gar nicht notwendig, den Kompatibilitätsmodus für Win98 zu verwenden.

In manchen Fällen hat es auch schon geholfen, Anno auf C:\Programme zu installieren. Klingt zwar komisch, wurde aber tatsächlich so berichtet. :)

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

5

Sunday, February 26th 2006, 4:14pm

hülfe

aaalso,

ich bin schon seit mehrern tagen am recherchieren, bei mir funzt anno-basisversion auch nicht. ich beschreibs mal detaillierter:
mein system:
amd xp 1800
768 mb ram
200 gb hdd
128 mb nvidia fx5200
soundblaster audigy 2 zs
via kt400 mainboard
win xp pro sp2, alle updates
neueste treiber für graka, mb und sound installiert

habe anno mit hilfe des installers in xp installiert. jetzt passiert folgendes: ich kann das spiel starten alles wunderbar, endlos, einführung, etc. aber nach ziemlich genau 10 minuten im spiel stürzt er einfach ab zurück zu windows ohne fehlermeldung, nix.

graka und soundbeschleunigung sind unten, ich spiele ohne musik, ohne sounds, ohne video. die auflösung ist die höchste, mal mit hardwareunterstützter maus, mal ohne.

mein tipp ist, dass es am automatischen speichern liegt. ich habe also in c:\programme\anno1602 den savegame ordner rechtsgeklickt. jetzt steht unten bei schreibgeschützt aber kein häkchen, aber weiß ist es auch nicht, sondern komplett ausgefüllt. das ist doch normalerweise das zeichen, dass nur ein teil der dateien im ordner schreibgeschützt ist aber nicht alle. im ordner selbst gibts nur "game00.gam" und "lastgame.gam", die beiden sind aber sicher nicht schreibgeschützt. wenn ich jetzt bei den eigenschaften vom ordner savegame das feld weiß mache(klicke) kommt die meldung ob ich auch alle dateien/ordner im ordner vom schreibschutz befreien will, dann klicke ich ja. das komische ist, wenn ich jetzt nochmal die eigenschaften von savegame öffne, ist das ausgefüllte kästchen wieder da.

ich bin sicher als admin angemeldet, habe also alle rechte. ich habe auch scon verschiedenste kompatibilitätsmodi probiert, keine auswirkung. vescheidentlich neuinstalliert, hilft nix.

woran könnte das noch liegen? und wenn es am automatischen speichern liegt, kann man das abstellen? oder in der game.dat den intervall ändern? der pfad in der game.dat ist auf jeden all der richtige.


PS: ach ja, das ganze läuft mit der original CD

This post has been edited 1 times, last edit by "jules" (Feb 26th 2006, 4:15pm)


Sir Henry

Oberbordschrauber

  • "Sir Henry" started this thread

Posts: 1,708

Date of registration: May 24th 2003

  • Send private message

6

Sunday, February 26th 2006, 5:08pm

Hallo jules,

der "graue" Schreibschutz für Ordner ist bei XP kein Problem, sondern normal. Wichtig ist, dass die Dateien game.dat im Anno-Hauptverzeichnis und lastgame.gam im savegame-Ordner nicht schreibgeschützt sind.

Und hast du das Spiel auch als Admin installiert?
  Cheers, Sir Henry
Schon im Anno-Pool vorbeigeschaut?

annokrat

Schatzjäger

Posts: 4,772

Date of registration: Nov 15th 2003

  • Send private message

7

Sunday, February 26th 2006, 5:09pm

ich nehme dennoch an, dass dir berechtigungen auf dem pfad fehlen.
überprüfe die berechtigungen über rechtsklick > eigenschaften > sicherheit.
kontrolliere ob du da wirklich vollzugriff hast.

annokrat
  anno 1503, das beste anno aller zeiten.
anno 1701, das anno für ewige anfänger.

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

8

Sunday, February 26th 2006, 5:26pm

das problem ist, dass es den reiter gar nicht gibt, es "allgemein", "Freigabe" und "Anpassen"... hm.

In den Benutzterkonten steht auch bei den Konten "Administrator" und "Jules" dass mein Status "Computeradministrator" ist, so muss es doch sein oder?

Vielen, vielen Dank schon mal für eure Hilfe

Sir Henry

Oberbordschrauber

  • "Sir Henry" started this thread

Posts: 1,708

Date of registration: May 24th 2003

  • Send private message

9

Sunday, February 26th 2006, 5:29pm

Schau bitte mal mit dem Befehl "attrib" von der Eingabeaufforderung nach, ob der Ordner schreibgeschützt ist.
  Cheers, Sir Henry
Schon im Anno-Pool vorbeigeschaut?

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

10

Sunday, February 26th 2006, 6:24pm

bei attrib kommt A. heißt das schreibgeschützt

W-O-D

Team AnnoZone

Posts: 7,095

Date of registration: Feb 3rd 2003

  • Send private message

11

Sunday, February 26th 2006, 6:57pm

Quoted

Original von jules
bei attrib kommt A. heißt das schreibgeschützt

Bedeutet nur das es Archiviert werden kann, ein rechtsklick auf Ordner oder Datei bringt ein Fenster wo das drinnsteht. ;)
  Ich will meinen Scout zurück :keule:

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

12

Sunday, February 26th 2006, 7:10pm

wie gesagt, der rechtsklick bringt nix neues, aber danke trotzdem.

ich hab mal ein bisschen rumgesucht. irgendwo gelesen, dass jemand es im abgesicherten modus installiert hat, bringt das was?

ich habe im gerätemanager gesehen, dass mein gameport deaktiviert ist, warum auch immer, aber das sollte ja nichts zu bedeuten haben oder?

annokrat

Schatzjäger

Posts: 4,772

Date of registration: Nov 15th 2003

  • Send private message

13

Sunday, February 26th 2006, 7:20pm

jules,
hör auf wild rumzuinstallieren. dieser abgesicherte-modus-quatsch ist unnötig.

wenn du keinen reiter "sicherheit" findest, dann hast du xp auf fat32 laufen. berechtigungen gibt es nur unter ntfs. unter eigenschaften siehst du auch das dateisystem, ich gehe davon aus, dass du dort fat32 finden wirst.

noch eine idee: du hast als "administrator" installiert und willst jetzt als "jules" spielen, oder umgekehrt.
gehe mal sicher, dass du als der benutzer spielst, der auch tatsächlich installiert hat.
... ist zwar wage, aber mehr fällt mir nicht mehr ein.

annokrat
  anno 1503, das beste anno aller zeiten.
anno 1701, das anno für ewige anfänger.

Sir Henry

Oberbordschrauber

  • "Sir Henry" started this thread

Posts: 1,708

Date of registration: May 24th 2003

  • Send private message

14

Sunday, February 26th 2006, 7:39pm

Mir auch nicht. Höchstens nochmal die Nachfrage nach der Hardwarebeschleunigung. Ist die wirklich auf Null, und zwar sowohl für Grafik als auch für Sound?
  Cheers, Sir Henry
Schon im Anno-Pool vorbeigeschaut?

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

15

Sunday, February 26th 2006, 7:45pm

ja ist sie, ich werd noch weiter probieren.

mal so ein gedanke: wie wäre es, das ganze emuliert von vmware zu probieren, meint ihr das würde laufen?

annokrat

Schatzjäger

Posts: 4,772

Date of registration: Nov 15th 2003

  • Send private message

16

Sunday, February 26th 2006, 7:54pm

sowas halte ich für einen hirnverbrannten gedankenansatz zur fehlerbehebung.

kannst dir ja auch einen neuen computer kaufen, vielleicht geht es mit dem.

annokrat
  anno 1503, das beste anno aller zeiten.
anno 1701, das anno für ewige anfänger.

jules

Frisch Angeheuert

Posts: 6

Date of registration: Feb 26th 2006

  • Send private message

17

Sunday, February 26th 2006, 8:33pm

sachte, sachte. ich probiers mal im sunflowers forum, vielleicht haben da noch welche zusätzliche vorschläge, euch vielen dank für die hilfe. wahrscheinlich liegts eh an irgendeiner kleinen einstellung, die ich übersehen habe...

W-O-D

Team AnnoZone

Posts: 7,095

Date of registration: Feb 3rd 2003

  • Send private message

18

Sunday, February 26th 2006, 8:47pm

Du schreibst ja oben "bei mir funzt anno-basisversion auch nicht" :rolleyes:
Vielleicht nimmste mal den Patch für XP und probierst es dann nochmal.
  Ich will meinen Scout zurück :keule:

FrankB

Boardsmutje

Posts: 953

Date of registration: Dec 14th 2003

  • Send private message

19

Sunday, February 26th 2006, 8:57pm

Nimm's nicht so... ;)

Ich gehe davon aus, daß Du recht hast und das Problem beim Speichern liegt.

Versuche es mal mit einer kompletten Neuinstallation:
  • Anno deinstallieren
  • sämtliche Verküpfungen zu Anno auf dem Desktop und im Startmenü löschen
  • Installationsverzeichnis löschen (normalerweise sollte man die game.dat und das Savegame-Verzeichnis vorher sichern, aber das dürfte bei Dir überflüssig sein)
  • in der Registry den Schlüssel HKEY_CURRENT_USER\Software\ANNO1602 löschen


Jetzt installierst Du Anno noch einmal neu.

Gonzo

Frisch Angeheuert

Posts: 9

Date of registration: Apr 13th 2006

  • Send private message

20

Thursday, April 13th 2006, 6:37pm

Guten Abend,

also ich hab das selbe Problem mit der Königsedition von Anno 1602. Habe auch Windows XP und das Spiel stürzt nach 10 Min. Spielzeit ab. Hab schon viel im Internet gesucht und alles mögliche probiert, sowohl die Tipps von der offiziellen Homepage as auch das mit der Grafikkarte und dem Sound. Da es anscheinend wirklich am Autosave liegt, wollte ich fragen, ob jemand weiss, wie man den abstellt. Oder, falls das Problem schon gelöst wurde, was man nun tun muss, damit das Spiel unter XP nicht einfach immer abstürzt.