You are not logged in.

Redeagle

Frisch Angeheuert

  • "Redeagle" started this thread

Posts: 4

Date of registration: May 24th 2010

  • Send private message

1

Wednesday, August 8th 2018, 7:07pm

Anno1602 im LAN - 2018

Hi
Ich hatte einen Flashback und wollte unbedingt wieder Anno (1602) zocken. Gesagt getan, kein Problem! Auch mit Win10 nicht.

Dann die Idee: LAN!
Den alten Vistarechner aktiviert (auf dem hatte ich auch schon erfolgreich 1602 gespielt), beide Versionen gecheckt (Update5), kann losgehen.
Nach ein bisschen gewurschtel fand ich auch den Host, aber ab Spielstart (Host win10 sieht die Schiffe) kackt der Client mit vista ab. Das Spiel wird geschlossen, keine Fehlermeldung. Der Host könnte spielen, aber das ist ja nicht der Sinn.
Hat jemand Erfahrung mit win10<->vista oder mit diesem Anno-Verhalten? Ich spiele von OrginalCD, ohne Addons. Singleplayer läufts an beiden Rechnern problemlos.

Oggy

Ausguck

Posts: 58

Date of registration: Sep 3rd 2003

  • Send private message

2

Friday, August 10th 2018, 6:03pm

Willkommen zurück Redeagle
Den alten Vistarechner aktiviert (auf dem hatte ich auch schon erfolgreich 1602 gespielt), beide Versionen gecheckt (Update5), kann losgehen.
Nach ein bisschen gewurschtel fand ich auch den Host, aber ab Spielstart (Host win10 sieht die Schiffe) kackt der Client mit vista ab. Das Spiel wird geschlossen, keine Fehlermeldung. Der Host könnte spielen, aber das ist ja nicht der Sinn.
Hat jemand Erfahrung mit win10<->vista oder mit diesem Anno-Verhalten? Ich spiele von OrginalCD, ohne Addons. Singleplayer läufts an beiden Rechnern problemlos.

Die LAN-Kompatibilität von Anno zwischen verschiedenen Betriebssystem ist auch im Heimnetzwerk und obwohl man das Host-Spiel sehen kann, nicht immer gegeben. Das liegt nicht an Anno, sondern am Unterbau DirectPlay - dies wurde 2004 - 2007 deprecated, und die Ersatz-Libraries verhalten sich je nach Windows-Version leicht unterschiedlich - teilweise werden andere Ports und Services genutzt. Dies kann sich zum Beispiel darin äußern, dass immer der letzte Mitspieler einer Partie nicht teilnehmen kann - egal in welcher Reihenfolge beigetreten wird. Aber es gibt immer eine Lösung :)
Dein Problem lässt sich daher nicht so einfach beantworten. Wenn Du mehr zu Deiner Konfiguration mitteilst, können wir Dir vielleicht helfen. Wenn Du eine schnelle(re) Lösung brauchst, würde ich Dir raten, zwei identische Windows-Versionen als VM auf Deinen beiden Rechnern laufen zu lassen. Von dort kannst Du bei Muße das Zusammenspiel mit Deinen normalen Systemen erkunden.

Redeagle

Frisch Angeheuert

  • "Redeagle" started this thread

Posts: 4

Date of registration: May 24th 2010

  • Send private message

3

Monday, September 3rd 2018, 6:36pm

Ich habs hinbekommen :thumbsup:

Kann zwar nicht dezidiert sagen was nun der Blocker war aber unter Vista scheint sich nach deaktivieren des AV-Programms (mit Firewall) die WinFirewall zu starten. Die habe ich nochmal extra deaktiviert, außerdem TCP-IPv6 deaktiviert und bei v4 Adressen vergeben. Und bei den erweiterten Freigabeeinstellungen nochmal auf die aktivierte Netzwerkkennung geachtet. (Die scheint immer wieder auf aus zu gehen beim rumprobieren).
Am Ende lief es.

Oggy

Ausguck

Posts: 58

Date of registration: Sep 3rd 2003

  • Send private message

4

Tuesday, September 4th 2018, 10:55am

Ich habs hinbekommen :thumbsup:

Kann zwar nicht dezidiert sagen was nun der Blocker war aber unter Vista scheint sich nach deaktivieren des AV-Programms (mit Firewall) die WinFirewall zu starten. Die habe ich nochmal extra deaktiviert, außerdem TCP-IPv6 deaktiviert und bei v4 Adressen vergeben. Und bei den erweiterten Freigabeeinstellungen nochmal auf die aktivierte Netzwerkkennung geachtet. (Die scheint immer wieder auf aus zu gehen beim rumprobieren).
Am Ende lief es.

Glückwunsch!

Jedoch wichtig für alle mit ähnlichen Problemen: Das Abschalten der Windows Firewall ist keine gute Lösung und wird nicht empfohlen.

Auch nicht im Heimnetzwerk. Windows Vista bekommt bereits keine Sicherheitsupdates mehr von Microsoft. Ein unbekannter Schädling des Mitspielers kann schnell zur Falle werden.

Wer Probleme mit der Heim-Netzwerkverbindung bei Anno hat, sollte zunächst ein aktuelles Betriebssystem einsetzen und dann gezielt Ports und Programme in der Firewall freigeben (ebenso im AV-Programm). Wenn das nicht funktioniert, kann eine virtuelle Maschine mit weniger Sicherheitseinstellungen eingesetzt werden, welche nach dem Spielen zurückgesetzt wird.

Über das Internet würde ich Anno 1602 derzeit nur über ein VPN spielen oder in einer Cloud-VM. Port-Weiterleitungen am Heim-Router wie zur Anfangszeit sind heute viel zu riskant - 1602 und DirectPlay sind zu alt, um Direktverbindungen an den eigenen Heimrechner zuzulassen. Viele starten ihr Anno sogar mit Administrator-Rechten um im Original-Spiel in die Savegame-Ordner schreiben zu können. Aber auch mit normalen Rechten wird die Freigabe im Internet schnell gefährlich :pirat: