Sie sind nicht angemeldet.

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

1

Donnerstag, 22. November 2018, 13:51

Das ewige Leid - Anno 1404 IAAM Absturz / Freeze - so gut wie alles probiert

Hi Leute,


ich habe, wie viele andere auch, das Absturzproblem. Nach ca. 20 Minuten friert das Spiel ein und stürzt einfach ab.
Ich spiele mit der Königsedition und IAAM v2.01.5010 (entspricht Patch 3.4 von der IAAM Seite), trotzdem habe ich das Thema mal hier eröffnet, da IAAM die Abstürze eigentlich nicht hervorrufen bzw. primär verantwortlich sein sollte.

Auch habe ich bisher so gut wie alles probiert, vielleicht kann dieses Thema endlich einen kompletten Überblick über alle Möglichkeiten geben und einiges zusammenfassen.


Ich habe bisher:
  • Die .exe-Dateien mit CFF getweakt (addon und anno4)
  • als Admin gestartet
  • die Internetverbindung schon gekappt (bringt nix)
  • sämtliche überflüssigen Programme ausgemacht (Steam, Nvidia und was sonst alles so läuft)
  • bestimmt vier mal das Spiel sauber neu installiert
  • den config Ordner unter Roaming umbenannt und damit quasi resettet
  • die Grafikeinstellungen reduziert (ebenfalls ohne Erfolg)
  • neue, getweakte .exe Dateien von der Annothek aus einem anderen Thread ausprobiert
  • immer nur ein Savegame im Spiel gespeichert
  • auf die Temperatur der GraKa geachtet, keine Probleme
  • das Programm in sämtlichen Kompatibilitätsmodi laufen lassen

Ich habe 16 GB Arbeitsspeicher und auch sonst kein schwaches System, DxDiag ist angehängt.

Würde es etwas bringen, die .exe in 64 bit zu "compilen"?

Das ist so ziemlich alles, was meines Wissens nach möglich ist. Gibt es eventuell noch andere Ideen oder wäre der nächste Schritt jetzt wirklich, das ganze System neu aufzusetzen, damit ich endlich dieses eigentlich geniale Spiel länger als 20 Minuten spielen kann?

Vielleicht kann dieses nervige Thema ja doch noch endgültig gelöst werden, bevor dann endlich Anno 1800 in den Release geht.
»Fusselhund« hat folgende Datei angehängt:
  • DxDiag.txt (72,58 kB - 38 mal heruntergeladen - zuletzt: Gestern, 12:23)

Admiral Drake

Schatzjäger

Beiträge: 2 108

Registrierungsdatum: 3. November 2004

  • Nachricht senden

2

Donnerstag, 22. November 2018, 15:55

Hallo Fusselhund.
Nach 20 Minuten kann der Speicher nicht aufgebraucht sein, ich hätte da ein paar ganz andere Dinge:
1. IAAM dürfte oder könnte ... - hilft nicht weiter. Läuft Anno 1404 ohne den IAAM korrekt ?
2. 20 Minuten - nach dem Start eines neuen Spieles ? Egal, was du baust ? Egal - welche Einstellungen ?
3. und wenn du das Spiel startest und 20 Minuten lang nichts machst - stürzt es dann noch immer ab ?

Leider kann ich mit einer dxdiag nichts anfangen, von Technik habe ich keine Ahnung, da musst du auf die Experten warten.
Ich versuche bei Fehlern nur immer, sie etwas einzukreisen.

Viel Glück
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

3

Donnerstag, 22. November 2018, 20:16

1. Keine Ahnung, nie getestet.
2. In einem fortgeschrittenen Endlosspiel, die Spielzeit verkürzt sich subjektiv mit der Dauer des vorangeschrittenen Spiels: Am Anfang konnte ich noch 2 Stunden spielen (Ich habe aber auch erst um die 15k Einwohner auf ner großen Map)
3. Probiere ich aus

Habe jetzt das ganze System neu aufgesetzt, mal sehen. Ich werde erstmal nur die Königsedition ohne den IAAM spielen und schauen ob es trotzdem abstürzt.

Auf welchen Lösungsansatz willst du denn hinaus?

Soricida

Piratenschreck

Beiträge: 676

Registrierungsdatum: 30. Dezember 2011

  • Nachricht senden

4

Donnerstag, 22. November 2018, 23:13

Moin Fusselhund,
hattest Du auch vor der Installation des I.A.A.M. 3.4 den Patch 3.1 für die Königsedition gemacht?
Gruß,
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

5

Donnerstag, 22. November 2018, 23:26

Ja, Spiel wurde gepacht mit dem 3.1 mit diesem offiziellen Ubi Link

Ich werde mal gleich clean reinstallen, dann erstmal nur Anno in der Königsedition spielen und gucken, was sich da tut.

Hat irgendjemand Erfahrungen zu den Kompatibilitätsmodi und deren Auswirkungen?

octo124

Steuermann

Beiträge: 196

Registrierungsdatum: 13. Januar 2007

  • Nachricht senden

6

Freitag, 23. November 2018, 07:03

Mehrere Ungereimtheiten in deiner DxDiag:
- BIOS-Version 1.40 - nimmt man das Board alleine, gibts bei MSI only Versionen mit 1.a -1.d sowie weitere neuere.
Mit CPU-Z bitte das Board konkret auslesen - Reiter Mainboard.
- Grafiktreiber veraltet - bitte nimm derzeit nicht unbedingt den aktuellsten von Nvidia (derzeit massive Baustelle), sondern die letzte 399.x-Version.

Diesbezüglich sind beide exe-Dateien explizit in der Nvidia-Systemsteuerung der 970 zugeordnet?
Auch verwunderlich, dass die Intel-iGPU nicht erkannt wird - ist diese im BIOS deaktiviert?

Nun kommt aber das, was nie im Input erwähnt wird - Ist 1404 als Standart installiert worden und liegt damit auf LW C? Da hast du eh zuwenig Platz = wenn, dann bitte benutzerdefiniert auf LW D installieren!
Installation wie folgt - egal um welches Benutzerkonto es sich handelt:
Setup per Rechtsklick - Ausführen als Admin - starten, dito auch die Patches. 1.Spielstart dito beide exe-Dateien per Rechtsklick etc. starten = einige versteckte Systemordner werden angelegt. Danach beenden und Neustart mit dem jeweiligen Benutzerkonto.
Kompatibilität - braucht man nicht (bei mir laufen beide exe der KE ohne auf LW E).
Abschliessend wie vom Admiral richtig erkannt - Spielprobleme testet man erst ausgiebig mit der jeweiligen Grundversion = läuft das ohne Probs, gibts auch beim IAMM keine (k.A. ob da evt. doch mit Kompatibilität gearbeitet werden sollte, der IAMM hats nicht auf meinen W10-PC geschafft.)

Abschliessende Frage - das W10 zuvor neu installiert worden oder doch älter, bei letzterem fehlen dann evt. wichtige 8 Fehlermeldungen.

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

7

Samstag, 24. November 2018, 08:13

Danke für die ausführlichen Ansätze, ich habe das System wie gesagt bereits neu aufgesetzt und muss mal ne neue DXDiag hochladen...Die anderen Sachen probiere ich die Tage aus, mal sehen ob es was bringt

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

8

Dienstag, 27. November 2018, 21:43

Mehrere Ungereimtheiten in deiner DxDiag:
- BIOS-Version 1.40 - nimmt man das Board alleine, gibts bei MSI only Versionen mit 1.a -1.d sowie weitere neuere.
...
Soo
BIOS geupdated (Screenshot)
NVIDIA Treiber auf besagte 399. Version aktualisiert
Zuordnung funktioniert nicht, da nur die GTX 970 aktiviert ist (sollte ich die HDgraphics aktivieren bzw. warum?

Anno ist nochmal sauber mit genügend Speicherplatz installiert worden, alles als Admin, Benutzerkonto ist Admin
Windows 10 ist aktuell, komplett neu und frisch aufgesetzt.

Freue mich weiterhin auf Eure Hilfe, Anno hat trotzdem den Speicherbug und nervt rum. Wie stabil jetzt ein großer Spielstand und das Game an sich ist, kann ich erst in ein paar Tagen sagen.

Falls euch noch was ein- oder an meinem System auffällt, bitte melden :)
»Fusselhund« hat folgendes Bild angehängt:
  • Mainboard.png
»Fusselhund« hat folgende Datei angehängt:
  • DxDiag.txt (68,04 kB - 2 mal heruntergeladen - zuletzt: 4. Dezember 2018, 00:38)

octo124

Steuermann

Beiträge: 196

Registrierungsdatum: 13. Januar 2007

  • Nachricht senden

9

Dienstag, 4. Dezember 2018, 00:57

Denke niemals hier, du bist vergessen worden - war anderweitig gefragt^^.
Hier den Screen vom 1, Post - hinzufügen, beide anno1404 exe-Dateien suchen, eintragen, fertig.
https://www.computerbase.de/forum/thread…weisen.1764571/


Der jetzige Absurz kann evt. an falscher Änderung des Eintrags zum 4 Gb-Patch liegen - einfach nochmal genau Anleitung lesen und kontrollieren.

Aber deine DxDiag strotz vor Fehlern:
- Update fehler W10 - sorry da hast du ein "optimierungsProg" im Einsatz, was falsch konfiguriert ist und für Normaluser unnötig ist.
Einfach fragen, wie man eine ungeliebte Funktion in W10 deaktiviert oder im Deskmodder-Wicki stöbern
- Fehler bei Erkennung Hardware. Kopiere dir die VID-Nr., suche im Netz nach a) evt. Lösungen o. b) wo du diese in deinen Win finden könntest und du hast die tangierte Hardware ermittelt.
Meine Vermutung, du hast zwar das BIOs geupdated, aber vergessen, die auch aktualisierten Treiber manuell zu aktualisieren.

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

10

Dienstag, 4. Dezember 2018, 19:48

Danke octo, dann werde ich erstmal weiter versuchen, meinen PC auf Vordermann zu bringen, bevor ich das mit Anno weiter in Angriff nehme. Danke für Eure ausführlichen Antworten, ich meld mich.

Und sonst geb ich den PC inem Spezi und der soll das da irgendwie installieren und zum Laufen kriegen wenn ich eifnach zu doof bin :D

octo124

Steuermann

Beiträge: 196

Registrierungsdatum: 13. Januar 2007

  • Nachricht senden

11

Dienstag, 4. Dezember 2018, 20:56

Oder such im Bekanntenkreis, Verwandschaft ob da einer ist, der dir per Teamviewer unter die Arme greifen kann - ist sicher preiswerter und du lernst einiges dabei, um Fehler nicht zu wiederholen.

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

12

Mittwoch, 5. Dezember 2018, 16:07

Ich frage mal und habe noch nen nützlichen Link gefunden, falls jemand das Thema ebenfalls verfolgt.
Sagt eigentlich nur, dass man auch die neueste DirectX Version installieren sollte
DirectPlay aktiviert
und als Admin und im Kompatibilitätsmodus Win 7 das Game ausführt.
Zusätzlich habe ich jetzt aufgrund der ComputerBase mir das Media Creation tool geholt und update mal auf das neueste Windows.

https://steamcommunity.com/app/33250/dis…17837633474474/

octo124

Steuermann

Beiträge: 196

Registrierungsdatum: 13. Januar 2007

  • Nachricht senden

13

Donnerstag, 6. Dezember 2018, 08:48

Auf manchen W10-Installationen scheint es - nie mich beschäftig zum warum - beim Einsatz anderer Programme/Games zu einem "Bug" bei Directx zu kommen. Geht problemlos zu fixen, indem man die irgendwie beschädigte Diretc-Datei nachbessert, indem man das DirectX 9.0c von 1404 installiert.

Viele W10-Nutzer vergessen, dass die Rechtevergabe wesentlich verschärft wurde gegenüber den Vorgängerversionen.
Deshalb richtig, als Admin installieren.
Auch hier kann man sein "Blaues Wunder " erleben, denn es gibt in W10 einen sichtbaren und einen unsichtbaren Admin.

Deshalb, egal mit welchem Benutzerkonto jedes Programm, egal ob Game oder sonstwas, die Setup-Datei nicht per Doppelklick!!, sondern per Rechtsklick - Ausführen als Admin (das ist der versteckte) - starten und schon werden alle Einträge auf LW C inkl. in den versteckten Systemordner angelegt.

Zur Kombatibilität hab ich eine andere Meinung = sowohl Grundspiel als auch Venedig müssen nicht auf W7 angepasst werden.

Fusselhund

Leichtmatrose

  • »Fusselhund« ist der Autor dieses Themas

Beiträge: 10

Registrierungsdatum: 9. September 2018

  • Nachricht senden

14

Gestern, 11:49

Tja, mittlerweile stürzt das Spiel bereits nach 4 Minuten ab...
Ich hab echt keine Ideen mehr. Habe mal mit und ohne CFF gestartet, stürzt nach der gleichen Zeit ab. (Fehlermeldung ist nach wie vor Speicher ist aufgebraucht).

Ich werde dann halt wohl nur leider auf 1800 und da ne neue Mod hoffen können.

AnnoZek

Is Seefest

Beiträge: 51

Registrierungsdatum: 3. April 2010

  • Nachricht senden

15

Gestern, 12:28

Wieviele HDMI-Ausgänge sind geschaltet ?

Wenn auf meiner Nvidia 1060 beide HDMI-Ausgänge (Monitor + TV) aktiviert sind (Anzeige dupliziert) geht Anno sofort in die Knie.

Ich kann ANNO nur spielen, wenn der Monitorausgang der einzig aktive ist.

Admiral Drake

Schatzjäger

Beiträge: 2 108

Registrierungsdatum: 3. November 2004

  • Nachricht senden

16

Gestern, 15:58

Du könntest mal den Rechner neu starten, nichts außer Anno starten, dein Savegame laden und in der Systemsteuerung nachsehen, wieviel Speicher Anno dort belegt hat.

CFF habe ich noch nie benutzt, bisher hat es immer gereicht, nur Anno zu starten und andere Anwendungen wegzulassen.
2 GB Speicher ist eigentlich ja schon eine ganze Menge ...

Wieviel EW hat denn dein Savegame (inkl. wieviel CGs) ?
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !