You are not logged in.

ninchen

Frisch Angeheuert

  • "ninchen" started this thread

Posts: 5

Date of registration: Feb 21st 2016

  • Send private message

1

Sunday, February 21st 2016, 3:53pm

Anno 1602 auf Windows 7

Halli Hallo!
Ich habe mir gestern Anno 1602 KE bei Media Markt gekauft, doch leider läuft es nicht! ;( Ich habe bereits etwas rumgegooglet und ausprobiert und hier im Forum nachgelesen, aber leider hat bisher nichts geholfen. Ich habe es mit dem Kompatibilitätsmodus versucht, mit Sir Henrys Anno 1602 Launcher, dann habe ich gelesen, dass jemand es über eine virtuelles Laufwerk hinbekommen hat, auch das habe ich probiert. Ich hab es mit dem vorgeschlagenen Verzeichnis und auch mit einem eigenen probiert, aber nix hat geholfen.
Wenn ich das Spiel startet sieht zunächst alles gut aus, das Spiel startet, die Videos werden angezeigt, das Spiel läuft, aber nach wenigen Minuten stockt das Spiel kurz, dann wird der Bildschirm schwarz, es kommt ein Fenster mit einer Fehlermeldung (sowas in Richtung "1602.exe funktioniert nicht richtig, es wird nach einer Lösung gesucht") und das spielt schließt.
Kann mir jemand mit diesem Problem helfen?
Lg ninchen =)

Soricida

Piratenschreck

Posts: 561

Date of registration: Dec 30th 2011

  • Send private message

2

Sunday, February 21st 2016, 6:54pm

Hallo ninchen,

willkommen in der AnnoZone

Hast Du Anno auch als "Adminestrator" gestartet?
Besitzt der Ordner von Anno 1602 auch "Schreibrechte"?

Das sind die beiden ersten Dinge, die mir dazu einfallen.

Gruß
Soricida
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Admiral Drake

Schatzjäger

Posts: 1,894

Date of registration: Nov 3rd 2004

  • Send private message

3

Sunday, February 21st 2016, 6:56pm

Ich kann die leider nicht helfen, aber je konkreter deine Angaben sind, desto eher meldet sich einer der Experten.
Eine dxdiag wäre in jedem Fall gut, ansonsten wo genau ist jetzt was installiert und wann genau kommt der btd, welche Anno-Version hast du gekauft (Publisher) etc.
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !

ninchen

Frisch Angeheuert

  • "ninchen" started this thread

Posts: 5

Date of registration: Feb 21st 2016

  • Send private message

4

Sunday, February 21st 2016, 7:06pm

@Soricida: Ja, als Administrator hab ich es gestartet. Schreibrechte hatte es nicht, hab es grad mal fix geändert, hat aber leider auch nicht geholfen.



Dxdaig hab ich angehängt.
Das Spiel ist installiert in D\Games\Anno und ich hab die Version von Green Pepper.
ninchen has attached the following file:
  • DxDiag.txt (25.16 kB - 48 times downloaded - latest: Sep 27th 2016, 7:14am)

Dickerbaer

Administrator

Posts: 4,233

Date of registration: May 1st 2004

  • Send private message

5

Sunday, February 21st 2016, 7:15pm

Mal eine Vermutung von mir. Wenn das Spiel "läuft" und dann abstürzt könnte es eventuell daran liegen, dass irgendwas verhindert, dass ein Savegame erstellt werden kann. Versuch mal herauszubekommen ob ich Recht habe indem du manuell abspeicherst.
  Höflichkeit ist die höchste Form der Verachtung!

ninchen

Frisch Angeheuert

  • "ninchen" started this thread

Posts: 5

Date of registration: Feb 21st 2016

  • Send private message

6

Sunday, February 21st 2016, 7:33pm

Manuell abspeichern geht und wenn ich ein neues Spiel anfange, kann ich auch relativ "lange" spielen, ich sag mal so 5 Minuten, bevor das Spiel abstürtzt. Wenn ich das vorher gespeicherte Spiel dann lade, dauert es nur wenige Augenblicke, bis es abstürzt.

W-O-D

Team AnnoZone

Posts: 6,693

Date of registration: Feb 3rd 2003

  • Send private message

7

Sunday, February 21st 2016, 7:49pm

Hast du mal probiert das ganze unter dem win98-kompatiblitäts-modus zu starten ?

Soricida

Piratenschreck

Posts: 561

Date of registration: Dec 30th 2011

  • Send private message

8

Sunday, February 21st 2016, 9:09pm

Ein echter Kompatibilitätsmodus ist mit WIN7 Home Premium nicht möglich.
(Die habe ich übrigens auch, und meine beiden Anno 1602 Versionen laufen.)

Du könntest noch versuchen, Deinen PC vom Internet zu trennen,
und dann Dein Virenprogramm zu beenden.
Aber wenn Du speichern kannst, glaube ich nicht, daß es hilft.

Das hört sich leider so ähnlich wie der "10 Minuten Bug" an.
GUstaf hatte dazu mal seinen einen Beitrag, hier hinterlassen.
"10 Min Absturz Problem mehr oder weniger gelöst"
Kannst Du Dich noch erinnern, welches Bild bei Dir dort zu sehen war?

PS: Wozu benutzt Du das USB-Laufwerk?

Wenn es zur Datensicherung ist, dann trenne es ansonsten immer vom PC.
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Soricida

Piratenschreck

Posts: 561

Date of registration: Dec 30th 2011

  • Send private message

9

Monday, February 22nd 2016, 11:10pm

Ich habe mal einen Selbsttest durchgeführt.
Meine Anno KE (von der GameStar) und die alte Anno 1602 + Erweiterungsset deinstalliert.
Und meine dritte Anno 1602 KE Version (von Sunflowers) installiert.
Die zeigte bei der Installation auch diese 4 Logos in allen Ecken an!!!
Aber auf meinem WIN7 (Home Premium 64bit) läuft, und läuft, und läuft... diese Anno1602 Version!
(Sorry, aber daher melde ich mich leider erst so spät wieder.) 8)
Darum kann diese Aussage von GUstaf (...Problem mehr, oder weniger gelöst) so allgemein doch nicht richtig sein!
Ich vermute mal irgend etwas fehlt noch in Deinem WIN7, aber was?

Ich grüble noch weiter an Deinem Problem,
Gruß
Soricida

PS: Besitzt Du noch andere Annos?
(1503, 1701, oder 1404?)
  Ich bin ja nicht neugierig, aber wissen möchte ich es schon!

Barbarella

Schatzjäger

Posts: 1,308

Date of registration: Jul 2nd 2005

  • Send private message

10

Wednesday, February 24th 2016, 3:26pm

@ninchen:

Welche Software hast du fuer das virtuelle Laufwerk benutzt?

Ist die iso nach dem Absturz noch im virtuellen Laufwerk geladen?

Hast du Anno definitiv nicht auf C: installiert? Das ist entscheidend. Nur ein anderes Verzeichnis auf C: bringt noch nicht viel. Volle Kontrolle hast du nur ueber eine andere Partition als C:.

Hast du DirectctX 9c nachinstalliert? Ich sehe, bei dir ist DX11 drauf. Das ist nicht abwaertskompatibel.

Irgendwie sieht das nach einer Art Schutzverletzung aus. Jedenfalls sehr ungewoehnlich.

ninchen

Frisch Angeheuert

  • "ninchen" started this thread

Posts: 5

Date of registration: Feb 21st 2016

  • Send private message

11

Thursday, February 25th 2016, 1:20pm

@ W-O-D: Ich habe alle Modi durchprobiert!

@ Sorcida: Ich hab ehrlich gesagt keine Meinung, welches Bild gemeint ist! :worry: Das externe Laufwerk benutze ich, weil ich kein internes hab!
Ja, ich habe noch 1503, war sone Doppel-Edition von Green Pepper und das läuft auch net! Das startet nicht mal!

@ Barbarella: Ich hab Virtual CloneDrive genommen! Die iso ist nach dem Absturz noch drin! Ja, es ist definitiv auf C: installiert! Och ich DirectX 9 hab, weiß ich ehrlich gesagt grad nich, aber ich check das mal!

Edit: Hab DirectX von der CD nachinstalliert, externes Laufwerk abgestöpselt und vom virtuellen Laufwerk gestartet und es läuft nach wie vor nicht! ?(






Aber danke schonmal, für die vielen Lösungsansätze! =)

Admiral Drake

Schatzjäger

Posts: 1,894

Date of registration: Nov 3rd 2004

  • Send private message

12

Thursday, February 25th 2016, 1:54pm

wenn du dich nicht verschrieben hast : es darf definitiv nicht auf C: installiert werden !
  Nur wer nichts tut, macht auch keine Fehler. Nicht meckern, sondern anpacken !

Dorimil

Insel-Eroberer

Posts: 434

Date of registration: Sep 16th 2009

  • Send private message

13

Thursday, February 25th 2016, 3:38pm

ich finde es schon interessant, daß die Videos bei dir laufen. Ich hab auch die Greenpepper version und das Spiel lief bei mir (Win 7 Prof 64bit) bis auf die Videos einwandfrei. Inzwischen habe ich mir die Version von GoG geholt, damit ich auch die Videos wieder geniessen kann. Nachteil der GP-Version ist ja, daß man die CD im Laufwerk benötigt (war bei mir so) und die GoG-Version kommt ohne aus.

Normalerweise, wenn das Spiel nicht auf C: installiert ist, wäre auch der Kompatibiltätsmodus nicht nötig...
  Lebe jeden Tag, als wäre es Dein Letzter!

ninchen

Frisch Angeheuert

  • "ninchen" started this thread

Posts: 5

Date of registration: Feb 21st 2016

  • Send private message

14

Thursday, February 25th 2016, 4:09pm

SOrry, hab mich verschrieben, meinte natürlich D:! Wie oben steht: D\Games\Anno!

Barbarella

Schatzjäger

Posts: 1,308

Date of registration: Jul 2nd 2005

  • Send private message

15

Thursday, February 25th 2016, 6:54pm

Das 1503 nicht läuft, finde ich jetzt doppelt merkwürdig. Das läuft unter Windows 7 eigentlich mit weniger Problemen als 1602.

Was ist denn das für ein Rechner, der kein internes DVD-Laufwerk hat? Sowas gibt es doch nur bei Netbooks und ultraflachen Notebooks.