Sie sind nicht angemeldet.

Sir Viper

Vollmatrose

Beiträge: 127

Registrierungsdatum: 14. Dezember 2011

  • Nachricht senden

21

Donnerstag, 8. Januar 2015, 02:16

Wenn die map ohne den Mod erstellt wurde und dann mit Mod gespielt wird, :idea: dann muß das Spiel doch crashen! :nono:
  "Zum Erfolg gibt es keinen Lift. Man muss die Treppe benutzen!"

Emil Oesch Schweizer Schriftsteller und Verleger (1894 – 1974)

Anno-Heiho

unregistriert

22

Donnerstag, 8. Januar 2015, 08:00

Wenn die map ohne den Mod erstellt wurde und dann mit Mod gespielt wird, :idea: dann muß das Spiel doch crashen! :nono:

Stimmt nicht ganz :eijoo:
Ich hab bei mir mal testweise eine Map geladen, die ohne Mods und Co erstellt worden ist.
Kein Crash und ähnliches. Spiel lief 2 Stunden Butterweich :thumbup:
Ich vermute mal eher, dass der Fehler daher kommt, dass Änderungen anstatt mit Tool1 und WE mit dem RDA Explorer gemacht worden sind und somit der Crash verursacht wird. Anno reagiert auf solche Veränderungen mehr als nur sensibel.

Kateker

Schatzjäger

Beiträge: 1 170

Registrierungsdatum: 26. Oktober 2006

  • Nachricht senden

23

Donnerstag, 8. Januar 2015, 22:12

Spricht nicht mehr mit uns.... wohl zu riskant^^

mr.know

Frisch Angeheuert

Beiträge: 5

Registrierungsdatum: 13. Januar 2015

  • Nachricht senden

24

Dienstag, 13. Januar 2015, 15:40

So wie Anno-Heiho bin ich auch vorgegangen!
  ...mit dem Herzen sehen!

Anno-Heiho

unregistriert

25

Donnerstag, 15. Januar 2015, 16:49

He, He Fehler gefindet :finger:

Anno, bzw. die Map crasht wenn:

--> Nachträgliche Änderungen im RDA Explorer gemacht werden und beim Speichern die
"volle" Komprimierung aktiviert wird (also alles angehakt)

--> Eine Mod installiert wird/ist, man eine Map erstellt und dann versucht das ganze
ohne die vorher installierte Mod zu verwenden

--> wenn man den falschen RDA Explorer (Vers. für Anno 2070) verwendet

--> wenn versucht wird, für Ressourcen, wie Stein, Eisen usw. einen höheren Wert wie 9999 zu verwenden
Dies wird erst sichtbar, wenn man die Map wieder im WE startet und sich dann die Ressourcen anschaut

Beim letzten Fehler: Dieser wurde von einem meiner Mod-Fans entdeckt, da in meiner Mod der Ressourcenabbau enorm höher ist, als im Originalspiel und ihm die Ressourcen binnen 5 min. leer gelaufen sind :g:

zum Vergleich:

Anno im Original, egal ob eigene Map oder Endlos kommt man mit 1 Pelzjagthütte einige Stunden aus

Anno mit Imperatormod: Hier ist es demjenigen aufgefallen !

Eine Pelzjagthütte mit "normalen" Ressourcenwerten ist binnen 3 Min. erschöpft. Ändert man nun via RDA Explorer den max. Wert für das Vorkommen, steht im WE plötzlich ein Wert von -9(irgendetwas)

Ich will hier ja niemanden vorab vorverurteilen, aber ich vermute mal, dass dies auch der "ursprüngliche" Grund seiner Fragen gewesen ist
:fluecht:
An dieser Stelle vielen Dank an denjenigen, von dem Ich die Mail mit der Ressourceninfo bekommen habe

andi4464

Plankenstürmer

Beiträge: 35

Registrierungsdatum: 9. April 2014

  • Nachricht senden

26

Sonntag, 25. Januar 2015, 09:42

huhu tut mir leid die späte antwort.

ich tu die rdu in den anhang. aber eigentlich sollte sie schon multiplayerfähig sein. Aber wirf lieber noch mal nen blick drauf... :rolleyes:

mfg andi

Die Datei lucius_in_mitte.rdu hat eine ungültige Dateiendung.

geht nicht man:(....ich kannst dir per email schicken wen du willst.

Anno-Heiho

unregistriert

27

Sonntag, 25. Januar 2015, 10:40

Die Datei lucius_in_mitte.rdu hat eine ungültige Dateiendung.
Versuch mal, das "Ding" in ein zip zu packen, dann sollte es gehen :pirat:

Serp

Frisch Angeheuert

Beiträge: 3

Registrierungsdatum: 15. Mai 2016

  • Nachricht senden

28

Sonntag, 15. Mai 2016, 00:31

Zu dem "notepad++" steht hier in irgend einem anderem Thema,
daß es nur mit älteren Versionen funktioniert! Die Neuen machen es nicht mehr.
Bei dem Neuen kann man aber die verschiedensten Einstellungen auswählen.
Leider hat hier aber noch keiner die passenden gefunden, oder gepostet.

Gruß
Soricida
Wollte nur mal für diejenigen die dasselbe Problem haben eine Lösung posten:
Wenn man im Notepad++ trotz der engine.ini savegame 0 änderung die savegame datei nicht lesen kann, klappt es bei mir einfach auf den Menüpunkt Kodierung unter Zeichensätze einen beliebigen Zeichensatz anzuklicken. Danach wird ist es plötzlich lesbar, ohne dass an der datei was geändert wird.

Habe einige Zeit rumgetüftelt bis ich das rausgefunden hab... mit dem rda Explorer klappt es nämlich wirklich nicht (man kann die datei zwar ändern, aber wenn man dann im MP das spiel öffnen will, kommt die meldung dass die partie bereits gestartet sei). Hoffe ich kann so den nächsten die durch Suchen auf diesen Thread stoßen viel Ärger ersparen :)

edit:
ich habe übrigens auch einige stunden google und diverse foren durchforstet, bis ich diese Anleitung in diesem Thread hier gefunden habe! Das hier ist tatsächlich die einzige vollständige Anleitung die ich finden konnte. Alle anderen exisitieren nicht mehr oder sind unvollständig (es fehlt zb der hinweis dass die engine.ini geändert werden muss).
Daher wäre es evlt sinnvoll, den Thread auch zu den wichtigen Themen zuzufügen?

Kateker

Schatzjäger

Beiträge: 1 170

Registrierungsdatum: 26. Oktober 2006

  • Nachricht senden

29

Sonntag, 15. Mai 2016, 09:26

Gut zu wissen, das mit Notepad++!

Habe mir extra eine älter Version aufgehoben, aber wenn diese Lösung funktioniert, super! :up:

Naver789

Landratte

Beiträge: 1

Registrierungsdatum: 5. September 2016

  • Nachricht senden

30

Montag, 5. September 2016, 17:00

Bei mir funkt es noch nicht ganz. Ich hab die Engine.ini geändert genau so wie es in der anleitung steht aber die .RDU ist trotzdem nur 40Kb groß und die .sww(savegame) 18 MB. könnte es daran liegen oder passt das so?
Außerdem hab ich manche sachen nicht geändert: Spieler- Bild, -ID und -Symbol. Diese Zeilen hab ich unberührt lassen. Ich wollte die chance das ich etwas falsch mache so niedrig wie nur möglich halten.
Und die bei Punkt 4.1 erwähnten Nuller hab ich bei dem Namen nicht, ich hab da nur einen Abstand zwischen jeden Buchstaben, ich hab aber trotzdem nur die buchstaben ersetzt und nichts gelöscht, funktioniert aber trotzdem nicht.
Bei mir wird das Gespeicherte spiel nicht im Multiplayer spiel angezeigt, obwohl er im "SaveGames" ordner ist.

eremit

Frisch Angeheuert

Beiträge: 2

Registrierungsdatum: 15. Juni 2017

  • Nachricht senden

31

Sonntag, 18. Juni 2017, 18:38

Hallo
Die etwas schwierige Handarbeit ein Single Savegame in ein MP Savegame zu ändern, besonders die unterschiedliche Kodierung der NP++ Versionen haben wir uns einmal vorgenommen. Wir haben ein Programm geschrieben welches die ganzen bekannten Änderungen am Savegame vornimmt und auch noch einiges mehr was nicht bekannt war. Da Ergebnis ist ein Savegame mit geänderten Bildern, Namen und Symbolen. Wobei die Namen dann ja beim Spiel durch die im jeweiligen Profil stehenden ersetzt werden. Das Ergebnis haben wir ausgiebig über Tunngle im MP KOOP getestet.
MfG eremit

Kateker

Schatzjäger

Beiträge: 1 170

Registrierungsdatum: 26. Oktober 2006

  • Nachricht senden

32

Samstag, 24. Juni 2017, 07:57

Ja, wirklich, das war immer schwierige Handarbeit!

Und was mir nie gelungen ist, dass der Spieler beim Start seinen gwünschten Avatar mitnehmen konnte.
Konntet ihr auch das umsetzen?